summaryrefslogtreecommitdiffstats
path: root/pki/base/setup/CMakeLists.txt
diff options
context:
space:
mode:
authorasn <asn@c9f7a03b-bd48-0410-a16d-cbbf54688b0b>2010-12-17 21:14:36 +0000
committerasn <asn@c9f7a03b-bd48-0410-a16d-cbbf54688b0b>2010-12-17 21:14:36 +0000
commite739c60c799d8a36e29a26f1e372608a661ff9a2 (patch)
treebb20fe4ce8a7fa6e475e8687efe68c1e04fdf650 /pki/base/setup/CMakeLists.txt
parent26f4346b6bcbb6efdea35452db508a27664abe4c (diff)
downloadpki-e739c60c799d8a36e29a26f1e372608a661ff9a2.tar.gz
pki-e739c60c799d8a36e29a26f1e372608a661ff9a2.tar.xz
pki-e739c60c799d8a36e29a26f1e372608a661ff9a2.zip
cmake: Fixed the setup directory creation on install.
git-svn-id: svn+ssh://svn.fedorahosted.org/svn/pki/trunk@1645 c9f7a03b-bd48-0410-a16d-cbbf54688b0b
Diffstat (limited to 'pki/base/setup/CMakeLists.txt')
-rw-r--r--pki/base/setup/CMakeLists.txt13
1 files changed, 2 insertions, 11 deletions
diff --git a/pki/base/setup/CMakeLists.txt b/pki/base/setup/CMakeLists.txt
index 457ceaf5c..e37306365 100644
--- a/pki/base/setup/CMakeLists.txt
+++ b/pki/base/setup/CMakeLists.txt
@@ -24,14 +24,5 @@ install(
)
# install empty directories
-install(
- DIRECTORY
- DESTINATION
- ${VAR_INSTALL_DIR}/lock/pki
-)
-
-install(
- DIRECTORY
- DESTINATION
- ${VAR_INSTALL_DIR}/run/pki
-)
+install(CODE "file(MAKE_DIRECTORY ${VAR_INSTALL_DIR}/lock/pki)")
+install(CODE "file(MAKE_DIRECTORY ${VAR_INSTALL_DIR}/run/pki)")