summaryrefslogtreecommitdiffstats
path: root/pki/base/native-tools/src/setpin/CMakeLists.txt
diff options
context:
space:
mode:
authorasn <asn@c9f7a03b-bd48-0410-a16d-cbbf54688b0b>2010-10-19 17:43:54 +0000
committerasn <asn@c9f7a03b-bd48-0410-a16d-cbbf54688b0b>2010-10-19 17:43:54 +0000
commit2a5f397f60b253d1dcdcedaa03ae0abd11095d0a (patch)
tree51d22395588d8a80c7e0311417c52e7e5c070cea /pki/base/native-tools/src/setpin/CMakeLists.txt
parent1755fbe4ed5aa2f11443c0415f49d8d6be32569d (diff)
downloadpki-2a5f397f60b253d1dcdcedaa03ae0abd11095d0a.tar.gz
pki-2a5f397f60b253d1dcdcedaa03ae0abd11095d0a.tar.xz
pki-2a5f397f60b253d1dcdcedaa03ae0abd11095d0a.zip
cmake: Added native-tools setpin executable.
git-svn-id: svn+ssh://svn.fedorahosted.org/svn/pki/trunk@1373 c9f7a03b-bd48-0410-a16d-cbbf54688b0b
Diffstat (limited to 'pki/base/native-tools/src/setpin/CMakeLists.txt')
-rw-r--r--pki/base/native-tools/src/setpin/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/pki/base/native-tools/src/setpin/CMakeLists.txt b/pki/base/native-tools/src/setpin/CMakeLists.txt
new file mode 100644
index 000000000..c10402782
--- /dev/null
+++ b/pki/base/native-tools/src/setpin/CMakeLists.txt
@@ -0,0 +1,43 @@
+project(setpin C)
+
+find_package(MozLDAP REQUIRED)
+
+set(SETPIN_PRIVATE_INCLUDE_DIRS
+ ${CMAKE_BINARY_DIR}
+ ${NSPR_INCLUDE_DIRS}
+ ${NSS_INCLUDE_DIRS}
+ ${MOZLDAP_INCLUDE_DIRS}
+)
+
+set(SETPIN_LINK_LIBRARIES
+ ${NSPR_LIBRARIES}
+ ${NSS_LIBRARIES}
+ ${MOZLDAP_LIBRARIES}
+)
+
+set(setpin_SRCS
+ b64.c
+ options.c
+ setpin.c
+ setpin_options.c
+)
+
+include_directories(${SETPIN_PRIVATE_INCLUDE_DIRS})
+
+add_executable(setpin ${setpin_SRCS})
+
+target_link_libraries(setpin ${SETPIN_LINK_LIBRARIES})
+
+install(
+ TARGETS setpin
+ RUNTIME DESTINATION ${BIN_INSTALL_DIR}
+ LIBRARY DESTINATION ${LIB_INSTALL_DIR}
+ ARCHIVE DESTINATION ${LIB_INSTALL_DIR}
+)
+
+install(
+ FILES
+ setpin.conf
+ DESTINATION
+ ${LIB_INSTALL_DIR}/pki/native-tools/
+)