summaryrefslogtreecommitdiffstats
path: root/base/tps/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAde Lee <alee@redhat.com>2012-08-15 14:06:08 -0400
committerAde Lee <alee@redhat.com>2012-08-15 14:06:08 -0400
commit75e1c66acb48e67951fc0ce5680328773fe837ae (patch)
tree0da680311142b5c2c80012eae86817aafeb1dad5 /base/tps/src/CMakeLists.txt
parent0198bf929702b756214b5f509ffe677ca58bf650 (diff)
downloadpki-75e1c66acb48e67951fc0ce5680328773fe837ae.tar.gz
pki-75e1c66acb48e67951fc0ce5680328773fe837ae.tar.xz
pki-75e1c66acb48e67951fc0ce5680328773fe837ae.zip
https://fedorahosted.org/pki/ticket/237
ECC support for tpsclient two parameters are added in the config file (see enroll.tps.ec for example): slotnamefile - this points to a file that contains the slot name. The reason why the slot name goes into another file instead of the conf file is because the existing conf file uses spaces for deliminator and I don't want to change the usage (and QE's tests) by changing it to something else. tokpasswod is the tokebn password This ECC feature requires the up-coming ECC supporting TPS to trigger. Testing of the ECC specific areas requires the availability of such ECC TPS. Without it, one can test with the old RSA method to see if it's broken.
Diffstat (limited to 'base/tps/src/CMakeLists.txt')
-rw-r--r--base/tps/src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/base/tps/src/CMakeLists.txt b/base/tps/src/CMakeLists.txt
index 5f588663c..b0276f8e2 100644
--- a/base/tps/src/CMakeLists.txt
+++ b/base/tps/src/CMakeLists.txt
@@ -79,6 +79,7 @@ set(tps_library_SRCS
apdu/Get_Data_APDU.cpp
apdu/External_Authenticate_APDU.cpp
apdu/Generate_Key_APDU.cpp
+ apdu/Generate_Key_ECC_APDU.cpp
apdu/Read_Buffer_APDU.cpp
apdu/Read_Object_APDU.cpp
apdu/Write_Object_APDU.cpp