summaryrefslogtreecommitdiffstats
path: root/base/tps/CMakeLists.txt
diff options
context:
space:
mode:
authorAde Lee <alee@redhat.com>2012-08-13 14:01:02 -0400
committerAde Lee <alee@redhat.com>2012-08-15 15:38:45 -0400
commit7a6b89591732f872db38821c00ec3ce89ef57e7a (patch)
tree4580ce2c5583ba2ff96b77ebdaa02f3c1287c406 /base/tps/CMakeLists.txt
parent87b5eaa5b1409bc362867e3849fe16c8f205afa9 (diff)
downloadpki-7a6b89591732f872db38821c00ec3ce89ef57e7a.tar.gz
pki-7a6b89591732f872db38821c00ec3ce89ef57e7a.tar.xz
pki-7a6b89591732f872db38821c00ec3ce89ef57e7a.zip
Changes to get TPS and RA running on dogtag 10
Added systemd scripts for RA and TPS. Modified init scripts and configuration files to use correct directives for httpd 2.4. TPS and RA subsystems are now installable using pkicreate
Diffstat (limited to 'base/tps/CMakeLists.txt')
-rw-r--r--base/tps/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/base/tps/CMakeLists.txt b/base/tps/CMakeLists.txt
index 96d23fefa..10c4d8efd 100644
--- a/base/tps/CMakeLists.txt
+++ b/base/tps/CMakeLists.txt
@@ -43,6 +43,19 @@ add_subdirectory(tools)
add_subdirectory(doc)
add_subdirectory(setup)
+# install systemd scripts
+install(
+ FILES
+ lib/systemd/system/pki-tpsd.target
+ lib/systemd/system/pki-tpsd@.service
+ DESTINATION
+ ${SYSTEMD_LIB_INSTALL_DIR}
+ PERMISSIONS
+ OWNER_EXECUTE OWNER_WRITE OWNER_READ
+ GROUP_EXECUTE GROUP_READ
+ WORLD_EXECUTE WORLD_READ
+)
+
# install init script
install(
FILES
@@ -206,3 +219,8 @@ install(
${SHARE_INSTALL_PREFIX}/${APPLICATION_NAME}/${PROJECT_NAME}/docroot/tps/admin/console/js
)
+install(
+ DIRECTORY
+ DESTINATION
+ ${SYSTEMD_ETC_INSTALL_DIR}/pki-tpsd.target.wants
+)