summaryrefslogtreecommitdiffstats
path: root/base/tps/CMakeLists.txt
diff options
context:
space:
mode:
authorChristina Fu <cfu@redhat.com>2012-08-15 13:32:14 -0700
committerChristina Fu <cfu@redhat.com>2012-08-15 13:32:14 -0700
commit7a5b5b06052a3432e1aec0aec8906cd5941f6fd9 (patch)
tree052bc470521dc24b5aa0b3552e594dbe11a4d660 /base/tps/CMakeLists.txt
parent3b1ca60d799ca02305b8a2c61eb279f74787cff0 (diff)
parent7a6b89591732f872db38821c00ec3ce89ef57e7a (diff)
downloadpki-7a5b5b06052a3432e1aec0aec8906cd5941f6fd9.tar.gz
pki-7a5b5b06052a3432e1aec0aec8906cd5941f6fd9.tar.xz
pki-7a5b5b06052a3432e1aec0aec8906cd5941f6fd9.zip
Merge branch 'master' of git://git.fedorahosted.org/git/pki
Diffstat (limited to 'base/tps/CMakeLists.txt')
-rw-r--r--base/tps/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/base/tps/CMakeLists.txt b/base/tps/CMakeLists.txt
index 96d23fefa..10c4d8efd 100644
--- a/base/tps/CMakeLists.txt
+++ b/base/tps/CMakeLists.txt
@@ -43,6 +43,19 @@ add_subdirectory(tools)
add_subdirectory(doc)
add_subdirectory(setup)
+# install systemd scripts
+install(
+ FILES
+ lib/systemd/system/pki-tpsd.target
+ lib/systemd/system/pki-tpsd@.service
+ DESTINATION
+ ${SYSTEMD_LIB_INSTALL_DIR}
+ PERMISSIONS
+ OWNER_EXECUTE OWNER_WRITE OWNER_READ
+ GROUP_EXECUTE GROUP_READ
+ WORLD_EXECUTE WORLD_READ
+)
+
# install init script
install(
FILES
@@ -206,3 +219,8 @@ install(
${SHARE_INSTALL_PREFIX}/${APPLICATION_NAME}/${PROJECT_NAME}/docroot/tps/admin/console/js
)
+install(
+ DIRECTORY
+ DESTINATION
+ ${SYSTEMD_ETC_INSTALL_DIR}/pki-tpsd.target.wants
+)