summaryrefslogtreecommitdiffstats
path: root/base/server/CMakeLists.txt
diff options
context:
space:
mode:
authorEndi S. Dewata <edewata@redhat.com>2013-07-10 14:55:31 -0400
committerEndi S. Dewata <edewata@redhat.com>2013-07-13 12:21:46 -0400
commitb3fad9255135e1f0347d07f3c8714f7d9a899b6c (patch)
treecb62c2b5287c24ab99a7ba107ab83e219d5bf722 /base/server/CMakeLists.txt
parentb5fd84a51def755fc02fbbf9bc35e58fb11beaf0 (diff)
downloadpki-b3fad9255135e1f0347d07f3c8714f7d9a899b6c.tar.gz
pki-b3fad9255135e1f0347d07f3c8714f7d9a899b6c.tar.xz
pki-b3fad9255135e1f0347d07f3c8714f7d9a899b6c.zip
Reorganized server files.
Some server files in base/common have been moved to base/server for consistency. The build scripts have been updated accordingly.
Diffstat (limited to 'base/server/CMakeLists.txt')
-rw-r--r--base/server/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/base/server/CMakeLists.txt b/base/server/CMakeLists.txt
index 8beedbb67..89fa033a8 100644
--- a/base/server/CMakeLists.txt
+++ b/base/server/CMakeLists.txt
@@ -52,6 +52,31 @@ install(
${PYTHON_SITE_PACKAGES}
)
+# install systemd scripts
+install(
+ DIRECTORY
+ share/lib/systemd/system/
+ DESTINATION
+ ${SYSTEMD_LIB_INSTALL_DIR}
+ FILE_PERMISSIONS
+ OWNER_EXECUTE OWNER_WRITE OWNER_READ
+ GROUP_EXECUTE GROUP_READ
+ WORLD_EXECUTE WORLD_READ
+)
+
+install(
+ FILES
+ setup/CertServer.directory
+ setup/menu.xml
+ setup/pkidaemon_registry
+ DESTINATION
+ ${DATA_INSTALL_DIR}/setup/
+ PERMISSIONS
+ OWNER_WRITE OWNER_READ
+ GROUP_READ
+ WORLD_READ
+)
+
# install executables
install(
FILES
@@ -117,6 +142,16 @@ install(
${DATA_INSTALL_DIR}/deployment
)
+# install server files
+install(
+ DIRECTORY
+ share/
+ DESTINATION
+ ${DATA_INSTALL_DIR}/server/
+ PATTERN
+ "lib/*" EXCLUDE
+)
+
# install server configuration files
install(
DIRECTORY