summaryrefslogtreecommitdiffstats
path: root/base/server/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Heimes <cheimes@redhat.com>2016-03-02 19:24:28 +0100
committerChristian Heimes <cheimes@redhat.com>2016-03-03 21:44:23 +0100
commit0e35b64c1f751cc8a7a8a0fac25828a8eab24714 (patch)
treeef68de896af93b309f32615d8e2a63490f56a805 /base/server/CMakeLists.txt
parentce049a83d78c30d0664c5d337766b222ef89202b (diff)
downloadpki-0e35b64c1f751cc8a7a8a0fac25828a8eab24714.tar.gz
pki-0e35b64c1f751cc8a7a8a0fac25828a8eab24714.tar.xz
pki-0e35b64c1f751cc8a7a8a0fac25828a8eab24714.zip
Simplify Python package installation
* The cmake files now copy just *.py into the installation directory. This ensures that no stale pyc files or __pycache__ directories are copied. rpmbuilder takes care of pyc/pyo compilation on Fedora and RHEL. * The pki-core.spec file uses python2 macros. In case of RHEL missing macros are defined on the top of the file. * A bug in the python_sitelib macros has been fixed. rpmbuilder doesn't like lines breaks.
Diffstat (limited to 'base/server/CMakeLists.txt')
-rw-r--r--base/server/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/base/server/CMakeLists.txt b/base/server/CMakeLists.txt
index 058cbf167..c4c6baacf 100644
--- a/base/server/CMakeLists.txt
+++ b/base/server/CMakeLists.txt
@@ -35,9 +35,11 @@ install(
# install Python libraries
install(
DIRECTORY
- python/
+ python/pki/server
DESTINATION
- ${PYTHON_SITE_PACKAGES}
+ ${PYTHON_SITE_PACKAGES}/pki/server
+ FILES_MATCHING PATTERN
+ *.py
)
# install systemd scripts