summaryrefslogtreecommitdiffstats
path: root/base/deploy/CMakeLists.txt
diff options
context:
space:
mode:
authorEndi Sukma Dewata <edewata@redhat.com>2012-11-28 18:59:06 -0500
committerEndi Sukma Dewata <edewata@redhat.com>2012-11-30 16:03:27 -0500
commit6344d6e7534696b9c236e818fe6f504bc957adaa (patch)
tree9ca8f34025c4d1e4471f861e630e8f38b8cc0b6a /base/deploy/CMakeLists.txt
parent471a49326ee8755bf2440962a36a30f4df619a17 (diff)
downloadpki-6344d6e7534696b9c236e818fe6f504bc957adaa.tar.gz
pki-6344d6e7534696b9c236e818fe6f504bc957adaa.tar.xz
pki-6344d6e7534696b9c236e818fe6f504bc957adaa.zip
Replaced links of scriptlets with lists.
Previously the deployment tools used symbolic links to determine the scriplets to execute and their order. The code has been changed such that now the scriplets are listed as parameters (spawn_scriplets and destroy_scriplets) in the configuration file. Ticket #403
Diffstat (limited to 'base/deploy/CMakeLists.txt')
-rw-r--r--base/deploy/CMakeLists.txt122
1 files changed, 0 insertions, 122 deletions
diff --git a/base/deploy/CMakeLists.txt b/base/deploy/CMakeLists.txt
index 26abe5346..3848bd499 100644
--- a/base/deploy/CMakeLists.txt
+++ b/base/deploy/CMakeLists.txt
@@ -117,125 +117,3 @@ install(
# install empty directories
install(CODE "file(MAKE_DIRECTORY \$ENV{DESTDIR}${VAR_INSTALL_DIR}/lock/pki)")
install(CODE "file(MAKE_DIRECTORY \$ENV{DESTDIR}${VAR_INSTALL_DIR}/run/pki)")
-
-# install subsystem directories for pkispawn and pkidestroy
-foreach(PKI_SUBSYSTEM ${PKI_SUBSYSTEMS})
- install(CODE "file(MAKE_DIRECTORY \$ENV{DESTDIR}${DATA_INSTALL_DIR}/deployment/spawn/${PKI_SUBSYSTEM})")
- install(CODE "file(MAKE_DIRECTORY \$ENV{DESTDIR}${DATA_INSTALL_DIR}/deployment/destroy/${PKI_SUBSYSTEM})")
-endforeach(PKI_SUBSYSTEM ${PKI_SUBSYSTEMS})
-
-# generate and install shared ordered 'scriptlet' symbolic links
-# for CA, KRA, OCSP, and TKS for pkispawn
-foreach(TOMCAT_SUBSYSTEM ${TOMCAT_SUBSYSTEMS})
- install(CODE "execute_process(COMMAND
- ${CMAKE_COMMAND} -E create_symlink
- \"${PYTHON_SITE_PACKAGES}/pki/deployment/initialization.py\"
- \"\$ENV{DESTDIR}${DATA_INSTALL_DIR}/deployment/spawn/${TOMCAT_SUBSYSTEM}/000_initialization\")"
- )
- install(CODE "execute_process(COMMAND
- ${CMAKE_COMMAND} -E create_symlink
- \"${PYTHON_SITE_PACKAGES}/pki/deployment/infrastructure_layout.py\"
- \"\$ENV{DESTDIR}${DATA_INSTALL_DIR}/deployment/spawn/${TOMCAT_SUBSYSTEM}/010_infrastructure_layout\")"
- )
- install(CODE "execute_process(COMMAND
- ${CMAKE_COMMAND} -E create_symlink
- \"${PYTHON_SITE_PACKAGES}/pki/deployment/instance_layout.py\"
- \"\$ENV{DESTDIR}${DATA_INSTALL_DIR}/deployment/spawn/${TOMCAT_SUBSYSTEM}/020_instance_layout\")"
- )
- install(CODE "execute_process(COMMAND
- ${CMAKE_COMMAND} -E create_symlink
- \"${PYTHON_SITE_PACKAGES}/pki/deployment/subsystem_layout.py\"
- \"\$ENV{DESTDIR}${DATA_INSTALL_DIR}/deployment/spawn/${TOMCAT_SUBSYSTEM}/030_subsystem_layout\")"
- )
- install(CODE "execute_process(COMMAND
- ${CMAKE_COMMAND} -E create_symlink
- \"${PYTHON_SITE_PACKAGES}/pki/deployment/selinux_setup.py\"
- \"\$ENV{DESTDIR}${DATA_INSTALL_DIR}/deployment/spawn/${TOMCAT_SUBSYSTEM}/035_selinux_setup\")"
- )
- install(CODE "execute_process(COMMAND
- ${CMAKE_COMMAND} -E create_symlink
- \"${PYTHON_SITE_PACKAGES}/pki/deployment/webapp_deployment.py\"
- \"\$ENV{DESTDIR}${DATA_INSTALL_DIR}/deployment/spawn/${TOMCAT_SUBSYSTEM}/040_webapp_deployment\")"
- )
- install(CODE "execute_process(COMMAND
- ${CMAKE_COMMAND} -E create_symlink
- \"${PYTHON_SITE_PACKAGES}/pki/deployment/slot_substitution.py\"
- \"\$ENV{DESTDIR}${DATA_INSTALL_DIR}/deployment/spawn/${TOMCAT_SUBSYSTEM}/050_slot_substitution\")"
- )
- install(CODE "execute_process(COMMAND
- ${CMAKE_COMMAND} -E create_symlink
- \"${PYTHON_SITE_PACKAGES}/pki/deployment/security_databases.py\"
- \"\$ENV{DESTDIR}${DATA_INSTALL_DIR}/deployment/spawn/${TOMCAT_SUBSYSTEM}/060_security_databases\")"
- )
- install(CODE "execute_process(COMMAND
- ${CMAKE_COMMAND} -E create_symlink
- \"${PYTHON_SITE_PACKAGES}/pki/deployment/configuration.py\"
- \"\$ENV{DESTDIR}${DATA_INSTALL_DIR}/deployment/spawn/${TOMCAT_SUBSYSTEM}/070_configuration\")"
- )
- install(CODE "execute_process(COMMAND
- ${CMAKE_COMMAND} -E create_symlink
- \"${PYTHON_SITE_PACKAGES}/pki/deployment/finalization.py\"
- \"\$ENV{DESTDIR}${DATA_INSTALL_DIR}/deployment/spawn/${TOMCAT_SUBSYSTEM}/999_finalization\")"
- )
-endforeach(TOMCAT_SUBSYSTEM ${TOMCAT_SUBSYSTEMS})
-
-# generate and install shared ordered 'scriptlet' symbolic links
-# for RA, and TPS for pkispawn
-
-# generate and install shared ordered 'scriptlet' symbolic links
-# for CA, KRA, OCSP, and TKS for pkidestroy
-foreach(TOMCAT_SUBSYSTEM ${TOMCAT_SUBSYSTEMS})
- install(CODE "execute_process(COMMAND
- ${CMAKE_COMMAND} -E create_symlink
- \"${PYTHON_SITE_PACKAGES}/pki/deployment/initialization.py\"
- \"\$ENV{DESTDIR}${DATA_INSTALL_DIR}/deployment/destroy/${TOMCAT_SUBSYSTEM}/000_initialization\")"
- )
- install(CODE "execute_process(COMMAND
- ${CMAKE_COMMAND} -E create_symlink
- \"${PYTHON_SITE_PACKAGES}/pki/deployment/configuration.py\"
- \"\$ENV{DESTDIR}${DATA_INSTALL_DIR}/deployment/destroy/${TOMCAT_SUBSYSTEM}/930_configuration\")"
- )
- install(CODE "execute_process(COMMAND
- ${CMAKE_COMMAND} -E create_symlink
- \"${PYTHON_SITE_PACKAGES}/pki/deployment/webapp_deployment.py\"
- \"\$ENV{DESTDIR}${DATA_INSTALL_DIR}/deployment/destroy/${TOMCAT_SUBSYSTEM}/940_webapp_deployment\")"
- )
-# install(CODE "execute_process(COMMAND
-# ${CMAKE_COMMAND} -E create_symlink
-# \"${PYTHON_SITE_PACKAGES}/pki/deployment/slot_substitution.py\"
-# \"\$ENV{DESTDIR}${DATA_INSTALL_DIR}/deployment/destroy/${TOMCAT_SUBSYSTEM}/950_slot_substitution\")"
-# )
- install(CODE "execute_process(COMMAND
- ${CMAKE_COMMAND} -E create_symlink
- \"${PYTHON_SITE_PACKAGES}/pki/deployment/subsystem_layout.py\"
- \"\$ENV{DESTDIR}${DATA_INSTALL_DIR}/deployment/destroy/${TOMCAT_SUBSYSTEM}/960_subsystem_layout\")"
- )
- install(CODE "execute_process(COMMAND
- ${CMAKE_COMMAND} -E create_symlink
- \"${PYTHON_SITE_PACKAGES}/pki/deployment/security_databases.py\"
- \"\$ENV{DESTDIR}${DATA_INSTALL_DIR}/deployment/destroy/${TOMCAT_SUBSYSTEM}/970_security_databases\")"
- )
- install(CODE "execute_process(COMMAND
- ${CMAKE_COMMAND} -E create_symlink
- \"${PYTHON_SITE_PACKAGES}/pki/deployment/instance_layout.py\"
- \"\$ENV{DESTDIR}${DATA_INSTALL_DIR}/deployment/destroy/${TOMCAT_SUBSYSTEM}/980_instance_layout\")"
- )
- install(CODE "execute_process(COMMAND
- ${CMAKE_COMMAND} -E create_symlink
- \"${PYTHON_SITE_PACKAGES}/pki/deployment/selinux_setup.py\"
- \"\$ENV{DESTDIR}${DATA_INSTALL_DIR}/deployment/destroy/${TOMCAT_SUBSYSTEM}/985_selinux_setup\")"
- )
- install(CODE "execute_process(COMMAND
- ${CMAKE_COMMAND} -E create_symlink
- \"${PYTHON_SITE_PACKAGES}/pki/deployment/infrastructure_layout.py\"
- \"\$ENV{DESTDIR}${DATA_INSTALL_DIR}/deployment/destroy/${TOMCAT_SUBSYSTEM}/990_infrastructure_layout\")"
- )
- install(CODE "execute_process(COMMAND
- ${CMAKE_COMMAND} -E create_symlink
- \"${PYTHON_SITE_PACKAGES}/pki/deployment/finalization.py\"
- \"\$ENV{DESTDIR}${DATA_INSTALL_DIR}/deployment/destroy/${TOMCAT_SUBSYSTEM}/999_finalization\")"
- )
-endforeach(TOMCAT_SUBSYSTEM ${TOMCAT_SUBSYSTEMS})
-
-# generate and install shared ordered 'scriptlet' symbolic links
-# for RA, and TPS for pkidestroy