summaryrefslogtreecommitdiffstats
path: root/base/deploy/CMakeLists.txt
diff options
context:
space:
mode:
authorEndi Sukma Dewata <edewata@redhat.com>2012-12-04 07:19:43 -0500
committerEndi Sukma Dewata <edewata@redhat.com>2012-12-04 12:15:50 -0500
commit20b8b11f2e6cf0395f4aecc42fa1873877ed9547 (patch)
tree1bc4fca9e6ad851b98175dee22fc4abdc2f2bd10 /base/deploy/CMakeLists.txt
parentb2e265466c6b183b707f9a1a8495e31cb121ddfd (diff)
downloadpki-20b8b11f2e6cf0395f4aecc42fa1873877ed9547.tar.gz
pki-20b8b11f2e6cf0395f4aecc42fa1873877ed9547.tar.xz
pki-20b8b11f2e6cf0395f4aecc42fa1873877ed9547.zip
Archiving default deployment configuration.ticket-399-8
The default deployment configuration file has been moved to /etc/pki/default.cfg to make it more accessible. The pkispawn has been modified to archieve the default deployment configuration along with the user-provided configuration in the registry. The pkidestroy has been modified to use both archived configuration files to ensure proper removal. Ticket #399
Diffstat (limited to 'base/deploy/CMakeLists.txt')
-rw-r--r--base/deploy/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/base/deploy/CMakeLists.txt b/base/deploy/CMakeLists.txt
index 3848bd499..a602d44a6 100644
--- a/base/deploy/CMakeLists.txt
+++ b/base/deploy/CMakeLists.txt
@@ -57,9 +57,16 @@ install(
install(
DIRECTORY
- config
+ config/
DESTINATION
- ${DATA_INSTALL_DIR}/deployment
+ ${DATA_INSTALL_DIR}/deployment/config
+)
+
+install(
+ DIRECTORY
+ etc/
+ DESTINATION
+ ${SYSCONF_INSTALL_DIR}/pki
)
find_package(PythonInterp REQUIRED)