summaryrefslogtreecommitdiffstats
path: root/base/deploy/CMakeLists.txt
diff options
context:
space:
mode:
authorEndi Sukma Dewata <edewata@redhat.com>2012-08-21 13:15:34 -0500
committerEndi Sukma Dewata <edewata@redhat.com>2012-09-05 10:08:41 -0500
commit63ac9595b4b193200e9b7af94f0854361a70eec9 (patch)
treee90039709931cd7783cbdb0276bf3e683704cf22 /base/deploy/CMakeLists.txt
parent1637107a208bc4ea465671ba0d9539548b4f1146 (diff)
downloadpki-63ac9595b4b193200e9b7af94f0854361a70eec9.tar.gz
pki-63ac9595b4b193200e9b7af94f0854361a70eec9.tar.xz
pki-63ac9595b4b193200e9b7af94f0854361a70eec9.zip
Moved webapp deployment code into pkispawn.
Previously the WAR files were generated at build time, so it would include theme files that were installed on the build machine. The code has been changed such that instead of generating WAR files pkispawn will copy the webapp files from the theme folders and combine them with subsystem webapp files at deployment time. This way it will use the actual theme files installed on the deployment machine. Ticket #89
Diffstat (limited to 'base/deploy/CMakeLists.txt')
-rw-r--r--base/deploy/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/base/deploy/CMakeLists.txt b/base/deploy/CMakeLists.txt
index 666a7704d..e0f65362b 100644
--- a/base/deploy/CMakeLists.txt
+++ b/base/deploy/CMakeLists.txt
@@ -86,7 +86,7 @@ install(
src/scriptlets/selinux_setup.py
src/scriptlets/slot_substitution.py
src/scriptlets/subsystem_layout.py
- src/scriptlets/war_explosion.py
+ src/scriptlets/webapp_deployment.py
DESTINATION
${PYTHON_SITE_PACKAGES}/pki/deployment
PERMISSIONS
@@ -149,8 +149,8 @@ foreach(TOMCAT_SUBSYSTEM ${TOMCAT_SUBSYSTEMS})
)
install(CODE "execute_process(COMMAND
${CMAKE_COMMAND} -E create_symlink
- \"${PYTHON_SITE_PACKAGES}/pki/deployment/war_explosion.py\"
- \"\$ENV{DESTDIR}${DATA_INSTALL_DIR}/deployment/spawn/${TOMCAT_SUBSYSTEM}/040_war_explosion\")"
+ \"${PYTHON_SITE_PACKAGES}/pki/deployment/webapp_deployment.py\"
+ \"\$ENV{DESTDIR}${DATA_INSTALL_DIR}/deployment/spawn/${TOMCAT_SUBSYSTEM}/040_webapp_deployment\")"
)
install(CODE "execute_process(COMMAND
${CMAKE_COMMAND} -E create_symlink
@@ -192,8 +192,8 @@ foreach(TOMCAT_SUBSYSTEM ${TOMCAT_SUBSYSTEMS})
)
install(CODE "execute_process(COMMAND
${CMAKE_COMMAND} -E create_symlink
- \"${PYTHON_SITE_PACKAGES}/pki/deployment/war_explosion.py\"
- \"\$ENV{DESTDIR}${DATA_INSTALL_DIR}/deployment/destroy/${TOMCAT_SUBSYSTEM}/940_war_explosion\")"
+ \"${PYTHON_SITE_PACKAGES}/pki/deployment/webapp_deployment.py\"
+ \"\$ENV{DESTDIR}${DATA_INSTALL_DIR}/deployment/destroy/${TOMCAT_SUBSYSTEM}/940_webapp_deployment\")"
)
# install(CODE "execute_process(COMMAND
# ${CMAKE_COMMAND} -E create_symlink