summaryrefslogtreecommitdiffstats
path: root/base/deploy/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthew Harmsen <mharmsen@redhat.com>2012-12-06 22:03:17 -0800
committerMatthew Harmsen <mharmsen@redhat.com>2012-12-06 22:06:01 -0800
commite7b7d9846060c8eb0e57b0e59047995cfc854569 (patch)
treecad996483e21bd70d2db4b8e96134740ddf25bed /base/deploy/CMakeLists.txt
parentcbfdae84f511ae526f1e7e29f71e7f60eef96094 (diff)
downloadpki-e7b7d9846060c8eb0e57b0e59047995cfc854569.tar.gz
pki-e7b7d9846060c8eb0e57b0e59047995cfc854569.tar.xz
pki-e7b7d9846060c8eb0e57b0e59047995cfc854569.zip
Added man pages.
* TRAC Ticket #315 - Man pages for pkispawn/pkidestroy. * Added place-holders for 'pki.1' and 'pki_default.cfg.5' man pages.
Diffstat (limited to 'base/deploy/CMakeLists.txt')
-rw-r--r--base/deploy/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/base/deploy/CMakeLists.txt b/base/deploy/CMakeLists.txt
index 3b1d9f583..94abccdbc 100644
--- a/base/deploy/CMakeLists.txt
+++ b/base/deploy/CMakeLists.txt
@@ -23,6 +23,29 @@ set(APACHE_SUBSYSTEMS
install(
FILES
+ man/man5/pki_default.cfg.5
+ DESTINATION
+ ${MAN_INSTALL_DIR}/man5
+ PERMISSIONS
+ OWNER_EXECUTE OWNER_WRITE OWNER_READ
+ GROUP_EXECUTE GROUP_READ
+ WORLD_EXECUTE WORLD_READ
+)
+
+install(
+ FILES
+ man/man8/pkispawn.8
+ man/man8/pkidestroy.8
+ DESTINATION
+ ${MAN_INSTALL_DIR}/man8
+ PERMISSIONS
+ OWNER_EXECUTE OWNER_WRITE OWNER_READ
+ GROUP_EXECUTE GROUP_READ
+ WORLD_EXECUTE WORLD_READ
+)
+
+install(
+ FILES
src/pkispawn
src/pkidestroy
DESTINATION