summaryrefslogtreecommitdiffstats
path: root/base/deploy/CMakeLists.txt
diff options
context:
space:
mode:
authorEndi Sukma Dewata <edewata@redhat.com>2012-12-06 13:06:14 -0500
committerEndi Sukma Dewata <edewata@redhat.com>2012-12-06 21:23:11 -0500
commit9996d71e1a4fb7a8ca6752b83e4f2393dbefa76b (patch)
tree449a55d01c5092a59192e0dffd28bbeb1c6e17f9 /base/deploy/CMakeLists.txt
parent883e0ec158eec04547da6856dbdaef0a8f640cb0 (diff)
downloadpki-9996d71e1a4fb7a8ca6752b83e4f2393dbefa76b.tar.gz
pki-9996d71e1a4fb7a8ca6752b83e4f2393dbefa76b.tar.xz
pki-9996d71e1a4fb7a8ca6752b83e4f2393dbefa76b.zip
Parameterizing RESTEasy paths.
The paths to RESTEasy jar files have been modified such that it can be configured globally at build time using the spec file to support different distributions, and at deployment time using a system-wide configuration in /etc/pki/pki.conf. Ticket #422, #423.
Diffstat (limited to 'base/deploy/CMakeLists.txt')
-rw-r--r--base/deploy/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/base/deploy/CMakeLists.txt b/base/deploy/CMakeLists.txt
index d63176f1a..3b1d9f583 100644
--- a/base/deploy/CMakeLists.txt
+++ b/base/deploy/CMakeLists.txt
@@ -67,6 +67,19 @@ install(
etc/
DESTINATION
${SYSCONF_INSTALL_DIR}/pki
+ PATTERN "pki.conf" EXCLUDE
+)
+
+configure_file(
+ ${CMAKE_CURRENT_SOURCE_DIR}/etc/pki.conf
+ ${CMAKE_CURRENT_BINARY_DIR}/etc/pki.conf
+)
+
+install(
+ FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/etc/pki.conf
+ DESTINATION
+ ${SYSCONF_INSTALL_DIR}/pki/
)
find_package(PythonInterp REQUIRED)