summaryrefslogtreecommitdiffstats
path: root/base/deploy/CMakeLists.txt
diff options
context:
space:
mode:
authorEndi Sukma Dewata <edewata@redhat.com>2012-12-04 07:19:43 -0500
committerAde Lee <alee@redhat.com>2012-12-04 15:50:55 -0500
commit81bb209d0a3227f544b7b8e4ec3fc0631c8f3c47 (patch)
tree0d72fda5309de4cd1c23319995f0214d7c361e39 /base/deploy/CMakeLists.txt
parentcb3d05b1225137f9a54952045dace4fc1f9a99b8 (diff)
downloadpki-81bb209d0a3227f544b7b8e4ec3fc0631c8f3c47.tar.gz
pki-81bb209d0a3227f544b7b8e4ec3fc0631c8f3c47.tar.xz
pki-81bb209d0a3227f544b7b8e4ec3fc0631c8f3c47.zip
Archiving default deployment configuration.
The default deployment configuration has been renamed and moved to /etc/pki/default.cfg to make it more accessible to users. The pkispawn has been modified to archive the default deployment configuration along with the user-provided configuration in the registry. The pkidestroy will now use both archived configuration files to ensure proper removal of the subsystem. Ticket #399
Diffstat (limited to 'base/deploy/CMakeLists.txt')
-rw-r--r--base/deploy/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/base/deploy/CMakeLists.txt b/base/deploy/CMakeLists.txt
index 3848bd499..d63176f1a 100644
--- a/base/deploy/CMakeLists.txt
+++ b/base/deploy/CMakeLists.txt
@@ -62,6 +62,13 @@ install(
${DATA_INSTALL_DIR}/deployment
)
+install(
+ DIRECTORY
+ etc/
+ DESTINATION
+ ${SYSCONF_INSTALL_DIR}/pki
+)
+
find_package(PythonInterp REQUIRED)
execute_process(
COMMAND