summaryrefslogtreecommitdiffstats
path: root/base/common/python/setup.py
diff options
context:
space:
mode:
authorEndi S. Dewata <edewata@redhat.com>2016-02-24 22:22:10 +0100
committerAde Lee <alee@redhat.com>2016-02-26 13:12:14 -0500
commit935633c5ea9f2b5c4321d924af166367008ac4b3 (patch)
tree514fdf2533b8be3cc3fe7789a3736b294f6952ba /base/common/python/setup.py
parent1d58b883ff9d0056d89d74d30f1375ab12d01f03 (diff)
downloadpki-935633c5ea9f2b5c4321d924af166367008ac4b3.tar.gz
pki-935633c5ea9f2b5c4321d924af166367008ac4b3.tar.xz
pki-935633c5ea9f2b5c4321d924af166367008ac4b3.zip
Added Python wrapper for pki pkcs12-import.
A Python wrapper module has been added for the pki pkcs12-import command to provide a mechanism to implement a workaround for JSS import limitation. Additional fixes by cheimes have been merged into this patch: setup.py: We must track all sub-packages manually. pylint-build-scan.py: pylint confuses the 'pki' package with the 'pki' command. The workaround symlinks the command and analysis the command under its alternative name. https://fedorahosted.org/pki/ticket/1742
Diffstat (limited to 'base/common/python/setup.py')
-rw-r--r--base/common/python/setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/base/common/python/setup.py b/base/common/python/setup.py
index 16c1d1760..2ab033784 100644
--- a/base/common/python/setup.py
+++ b/base/common/python/setup.py
@@ -84,7 +84,7 @@ and set up in less than an hour.""",
license='GPL',
keywords='pki x509 cert certificate',
url='http://pki.fedoraproject.org/',
- packages=['pki'],
+ packages=['pki', 'pki.cli'],
requirements=['python-nss', 'requests', 'six'],
classifiers=[
'Development Status :: 5 - Production/Stable',