summaryrefslogtreecommitdiffstats
path: root/base/common/python/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Heimes <cheimes@redhat.com>2016-02-29 09:10:54 +0100
committerChristian Heimes <cheimes@redhat.com>2016-02-29 16:10:55 +0100
commitbcd8373696d6a1262234dd4d17874ac56107b381 (patch)
treef34a1ea5008644ac5d49f6f96f9a90a876f25839 /base/common/python/CMakeLists.txt
parentd5360c915761773e93333b6894df4bd8ac8a2f13 (diff)
downloadpki-bcd8373696d6a1262234dd4d17874ac56107b381.tar.gz
pki-bcd8373696d6a1262234dd4d17874ac56107b381.tar.xz
pki-bcd8373696d6a1262234dd4d17874ac56107b381.zip
Fail builds when sphinx-builder fails
sphinx-builder just reports errors to stderr but doesn't signal build failures in its return code. The -W option turns any warning into a non-null exit code. Comment out html_static_path. It doesn't exist, is not used but emits a warning which is then turned into an error.
Diffstat (limited to 'base/common/python/CMakeLists.txt')
-rw-r--r--base/common/python/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/base/common/python/CMakeLists.txt b/base/common/python/CMakeLists.txt
index 7c2fad869..d667421bf 100644
--- a/base/common/python/CMakeLists.txt
+++ b/base/common/python/CMakeLists.txt
@@ -19,6 +19,7 @@ add_custom_target(dogtag_python_client_docs ALL
-c "${CMAKE_CURRENT_BINARY_DIR}"
-w "${CMAKE_CURRENT_BINARY_DIR}/python-client-lib-html.log"
-a
+ -W
"${CMAKE_CURRENT_SOURCE_DIR}"
"${CMAKE_CURRENT_BINARY_DIR}/html"
COMMENT "Building Python Client Library HTML documentation")
@@ -29,6 +30,7 @@ add_custom_target(dogtag_python_client_man_docs ALL
-c "${CMAKE_CURRENT_BINARY_DIR}"
-w "${CMAKE_CURRENT_BINARY_DIR}/python-client-lib-man.log"
-a
+ -W
"${CMAKE_CURRENT_SOURCE_DIR}"
"${CMAKE_CURRENT_BINARY_DIR}/man"
COMMENT "Building Python Client Library manual pages")