summaryrefslogtreecommitdiffstats
path: root/base/common/python/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Heimes <cheimes@redhat.com>2016-03-01 11:08:59 +0100
committerChristian Heimes <cheimes@redhat.com>2016-03-01 19:05:43 +0100
commit298e15c16e266d2ca81e62354edb9dc5626c1f72 (patch)
treeea30117af6aa92d13ff7188451de933c0a030e1a /base/common/python/CMakeLists.txt
parent49e4fffe1681de5a5fb21de62cd4b7ed9505fc7a (diff)
downloadpki-298e15c16e266d2ca81e62354edb9dc5626c1f72.tar.gz
pki-298e15c16e266d2ca81e62354edb9dc5626c1f72.tar.xz
pki-298e15c16e266d2ca81e62354edb9dc5626c1f72.zip
Use CMAKE_CURRENT_SOURCE_DIR for sphinx-build
sphinx-build used wrong search path for pki Python package. This caused builds to fail on some machines. On systems with pki-base installed, sphinx-build picked up the wrong files.
Diffstat (limited to 'base/common/python/CMakeLists.txt')
-rw-r--r--base/common/python/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/base/common/python/CMakeLists.txt b/base/common/python/CMakeLists.txt
index d667421bf..a16459775 100644
--- a/base/common/python/CMakeLists.txt
+++ b/base/common/python/CMakeLists.txt
@@ -16,23 +16,27 @@ configure_file(
add_custom_target(dogtag_python_client_docs ALL
${SPHINX_EXECUTABLE}
-b html
- -c "${CMAKE_CURRENT_BINARY_DIR}"
+ -c "${CMAKE_CURRENT_SOURCE_DIR}"
-w "${CMAKE_CURRENT_BINARY_DIR}/python-client-lib-html.log"
-a
-W
"${CMAKE_CURRENT_SOURCE_DIR}"
"${CMAKE_CURRENT_BINARY_DIR}/html"
+ WORKING_DIRECTORY
+ ${CMAKE_CURRENT_SOURCE_DIR}
COMMENT "Building Python Client Library HTML documentation")
add_custom_target(dogtag_python_client_man_docs ALL
${SPHINX_EXECUTABLE}
-b man
- -c "${CMAKE_CURRENT_BINARY_DIR}"
+ -c "${CMAKE_CURRENT_SOURCE_DIR}"
-w "${CMAKE_CURRENT_BINARY_DIR}/python-client-lib-man.log"
-a
-W
"${CMAKE_CURRENT_SOURCE_DIR}"
"${CMAKE_CURRENT_BINARY_DIR}/man"
+ WORKING_DIRECTORY
+ ${CMAKE_CURRENT_SOURCE_DIR}
COMMENT "Building Python Client Library manual pages")
install(