summaryrefslogtreecommitdiffstats
path: root/base/common/CMakeLists.txt
diff options
context:
space:
mode:
authorEndi S. Dewata <edewata@redhat.com>2015-05-26 10:46:57 -0400
committerEndi S. Dewata <edewata@redhat.com>2015-05-28 12:02:03 -0400
commit68590caf838d7ef808d9b4c103df87530a9fe4aa (patch)
treefc3e6e7749dcf27962874ed5b05de39ba7c82d9c /base/common/CMakeLists.txt
parentc695c2abf0a2edb4878c1cf01fd3222821ae8fc9 (diff)
downloadpki-68590caf838d7ef808d9b4c103df87530a9fe4aa.tar.gz
pki-68590caf838d7ef808d9b4c103df87530a9fe4aa.tar.xz
pki-68590caf838d7ef808d9b4c103df87530a9fe4aa.zip
Cleaned up python docs generation.
The script to generate Python docs has been cleaned up and simplified. The python-sphinx configuration files have been moved into base/common/python. The build artifacts are now created in the build/base/common/python.
Diffstat (limited to 'base/common/CMakeLists.txt')
-rw-r--r--base/common/CMakeLists.txt10
1 files changed, 1 insertions, 9 deletions
diff --git a/base/common/CMakeLists.txt b/base/common/CMakeLists.txt
index 37139f78f..ee401f201 100644
--- a/base/common/CMakeLists.txt
+++ b/base/common/CMakeLists.txt
@@ -25,14 +25,6 @@ install(
${SYSCONF_INSTALL_DIR}/pki/
)
-# install Python libraries
-install(
- DIRECTORY
- python/
- DESTINATION
- ${PYTHON_SITE_PACKAGES}
-)
-
# install executables
install(
FILES
@@ -105,4 +97,4 @@ install(
)
add_subdirectory(src)
-add_subdirectory(python/docs)
+add_subdirectory(python)