summaryrefslogtreecommitdiffstats
path: root/base/CMakeLists.txt
diff options
context:
space:
mode:
authorEndi Sukma Dewata <edewata@redhat.com>2012-09-30 12:21:46 -0500
committerAde Lee <alee@redhat.com>2012-10-01 14:15:44 -0400
commitf81718c563ea12240e161a807013acd2d6eb1f2e (patch)
tree2aa664ed414086ac0a19c7eb6b0ac9e3a57af256 /base/CMakeLists.txt
parentaa1c7e757ee01759cb08f3dd5d0556cfe2ef8e32 (diff)
downloadpki-f81718c563ea12240e161a807013acd2d6eb1f2e.tar.gz
pki-f81718c563ea12240e161a807013acd2d6eb1f2e.tar.xz
pki-f81718c563ea12240e161a807013acd2d6eb1f2e.zip
Using RPM version number in CMake.
The RPM spec files have been modified to pass the full RPM version number to CMake. The version number contains the product version number, release number, milestone, and platform. The CMake scritps will parse and use this version number to generate Java manifest files. The product version number will be used as the specification version and full version number will be used as the implementation version. Ticket #339
Diffstat (limited to 'base/CMakeLists.txt')
-rw-r--r--base/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/base/CMakeLists.txt b/base/CMakeLists.txt
index 310a3e3c8..c0de97171 100644
--- a/base/CMakeLists.txt
+++ b/base/CMakeLists.txt
@@ -21,7 +21,10 @@ if (APPLICATION_FLAVOR_PKI_CORE)
add_subdirectory(javadoc)
endif(WITH_JAVADOC)
- file(WRITE ${CMAKE_CURRENT_BINARY_DIR}/VERSION ${APPLICATION_VERSION})
+ configure_file(
+ ${CMAKE_CURRENT_SOURCE_DIR}/VERSION
+ ${CMAKE_CURRENT_BINARY_DIR}/VERSION
+ )
install(
FILES