summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEndi Sukma Dewata <edewata@redhat.com>2012-09-25 00:43:31 -0500
committerEndi Sukma Dewata <edewata@redhat.com>2012-09-28 09:42:24 -0500
commit9368ef42cea4e1e46f22628cffaa29fba66cfec6 (patch)
treecef737e524f9d19f919a5f3e260cc4bad6b35121 /CMakeLists.txt
parent854ecce0fc312e65804d84041cbc93b17cce88a5 (diff)
downloadpki-9368ef42cea4e1e46f22628cffaa29fba66cfec6.tar.gz
pki-9368ef42cea4e1e46f22628cffaa29fba66cfec6.tar.xz
pki-9368ef42cea4e1e46f22628cffaa29fba66cfec6.zip
Added VERSION file.
The CMake scripts have been modified to store the version number in /usr/share/pki/VERSION and in JAR manifest files. These files can be read by PKI applications to obtain the version number without having to query the RPM database. Fixed warnings in Java.cmake file. Ticket #339
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b99211bd4..bf61fbc48 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -65,7 +65,6 @@ macro_ensure_out_of_source_build("${PROJECT_NAME} requires an out of source buil
# add macros
include(MacroCopyFile)
include(Java)
-include(UseJava)
file(MAKE_DIRECTORY ${CMAKE_BINARY_DIR}/classes)
file(MAKE_DIRECTORY ${CMAKE_BINARY_DIR}/dist)
@@ -170,4 +169,3 @@ elseif (APPLICATION_FLAVOR_DOGTAG_PKI_THEME)
elseif (APPLICATION_FLAVOR_REDHAT_PKI_THEME)
add_subdirectory(redhat)
endif ()
-