summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEndi Sukma Dewata <edewata@redhat.com>2012-03-23 10:44:33 -0500
committerEndi Sukma Dewata <edewata@redhat.com>2012-03-26 12:54:21 -0500
commit78378144e71a00a67690a1f99152402c892b0103 (patch)
treead4a0fb27d54d0b5da4adfe6b9626cab7a939c69 /CMakeLists.txt
parent621d9e5c413e561293d7484b93882d985b3fe15f (diff)
downloadpki-78378144e71a00a67690a1f99152402c892b0103.tar.gz
pki-78378144e71a00a67690a1f99152402c892b0103.tar.xz
pki-78378144e71a00a67690a1f99152402c892b0103.zip
Added option to build without Javadoc.
The build scripts have been modified to provide an option to build without Javadoc to speed up development builds. The option can be used as follows: compose_pki_core_packages --without-javadoc hybrid_rpms Ticket #111
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 953250259..d6c5d823e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,8 @@ set(APPLICATION_VERSION_MAJOR "10")
set(APPLICATION_VERSION_MINOR "0")
set(APPLICATION_VERSION_PATCH "0")
+option(WITH_JAVADOC "Build with Javadoc" ON)
+
if (BUILD_IPA_PKI_THEME)
set(APPLICATION_FLAVOR_IPA_PKI_THEME TRUE)
# override APPLICATION VERSION