summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEndi Sukma Dewata <edewata@redhat.com>2012-11-22 02:23:24 -0500
committerEndi Sukma Dewata <edewata@redhat.com>2012-12-03 11:40:53 -0500
commita4c95c3d9fd9814eb3b1bbb7d987d906e423a42e (patch)
tree72279336c4c62bed682be5aed431a519acce004c
parent3dfee9129baeac450134813ce9f7c7644efed4dc (diff)
downloadpki-a4c95c3d9fd9814eb3b1bbb7d987d906e423a42e.zip
pki-a4c95c3d9fd9814eb3b1bbb7d987d906e423a42e.tar.gz
pki-a4c95c3d9fd9814eb3b1bbb7d987d906e423a42e.tar.xz
Removed RA and TPS theme packages.
The RA and TPS theme packages are no longer necessary due to the reorganization of the theme files. The build and deployment scripts have been updated accordingly. Ticket #407
-rw-r--r--base/ra/CMakeLists.txt8
-rwxr-xr-xbase/setup/pkicreate7
-rw-r--r--base/tps/CMakeLists.txt19
-rw-r--r--dogtag/CMakeLists.txt2
-rw-r--r--specs/dogtag-pki-theme.spec83
5 files changed, 26 insertions, 93 deletions
diff --git a/base/ra/CMakeLists.txt b/base/ra/CMakeLists.txt
index 79152e2..ece6713 100644
--- a/base/ra/CMakeLists.txt
+++ b/base/ra/CMakeLists.txt
@@ -37,16 +37,16 @@ install(
install(
DIRECTORY
- emails/
+ apache/docroot
DESTINATION
- ${SHARE_INSTALL_PREFIX}/${APPLICATION_NAME}/${PROJECT_NAME}/conf
+ ${SHARE_INSTALL_PREFIX}/${APPLICATION_NAME}/${PROJECT_NAME}
)
install(
DIRECTORY
- forms/
+ emails/
DESTINATION
- ${SHARE_INSTALL_PREFIX}/${APPLICATION_NAME}/${PROJECT_NAME}/docroot
+ ${SHARE_INSTALL_PREFIX}/${APPLICATION_NAME}/${PROJECT_NAME}/conf
)
install(
diff --git a/base/setup/pkicreate b/base/setup/pkicreate
index 6f63e96..a9ac189 100755
--- a/base/setup/pkicreate
+++ b/base/setup/pkicreate
@@ -2061,12 +2061,7 @@ sub process_pki_directories
$default_dir_permissions, $default_file_permissions,
$pki_user, $pki_group);
- return 0 if !copy_directory($ui_subsystem_path, $pki_instance_path,
- $default_dir_permissions, $default_file_permissions,
- $pki_user, $pki_group);
-
- # Copy /usr/share/pki/common-ui
- # to <instance>/docroot/pki
+ # Copy /usr/share/pki/common-ui to <instance>/docroot/pki
return 0 if !copy_directory(
$common_ui_subsystem_path,
"$docroot_instance_path/pki",
diff --git a/base/tps/CMakeLists.txt b/base/tps/CMakeLists.txt
index 10c4d8e..954146c 100644
--- a/base/tps/CMakeLists.txt
+++ b/base/tps/CMakeLists.txt
@@ -79,7 +79,7 @@ install(
install(
DIRECTORY
- forms/esc/cgi-bin
+ apache/cgi-bin
DESTINATION
${SHARE_INSTALL_PREFIX}/${APPLICATION_NAME}/${PROJECT_NAME}
)
@@ -92,21 +92,10 @@ install(
)
install(
- FILES
- forms/index.html
- DESTINATION
- ${SHARE_INSTALL_PREFIX}/${APPLICATION_NAME}/${PROJECT_NAME}/docroot
-)
-
-install(
- FILES
- forms/index.cgi
+ DIRECTORY
+ apache/docroot
DESTINATION
- ${SHARE_INSTALL_PREFIX}/${APPLICATION_NAME}/${PROJECT_NAME}/docroot
- PERMISSIONS
- OWNER_EXECUTE OWNER_WRITE OWNER_READ
- GROUP_EXECUTE GROUP_READ
- WORLD_EXECUTE WORLD_READ
+ ${SHARE_INSTALL_PREFIX}/${APPLICATION_NAME}/${PROJECT_NAME}
)
install(
diff --git a/dogtag/CMakeLists.txt b/dogtag/CMakeLists.txt
index aa4f2fc..2561495 100644
--- a/dogtag/CMakeLists.txt
+++ b/dogtag/CMakeLists.txt
@@ -5,7 +5,5 @@ if (APPLICATION_FLAVOR_IPA_PKI_THEME)
endif (APPLICATION_FLAVOR_IPA_PKI_THEME)
if (APPLICATION_FLAVOR_DOGTAG_PKI_THEME)
add_subdirectory(common-ui)
- add_subdirectory(ra-ui)
- add_subdirectory(tps-ui)
add_subdirectory(console-ui)
endif (APPLICATION_FLAVOR_DOGTAG_PKI_THEME)
diff --git a/specs/dogtag-pki-theme.spec b/specs/dogtag-pki-theme.spec
index 5e10a20..934dc42 100644
--- a/specs/dogtag-pki-theme.spec
+++ b/specs/dogtag-pki-theme.spec
@@ -7,7 +7,7 @@
Name: dogtag-pki-theme
Version: 10.0.0
-Release: %{?relprefix}8%{?prerel}%{?dist}
+Release: %{?relprefix}9%{?prerel}%{?dist}
Summary: Certificate System - Dogtag PKI Theme Components
URL: http://pki.fedoraproject.org/
License: GPLv2
@@ -75,6 +75,10 @@ Conflicts: redhat-pki-ocsp-theme
Conflicts: redhat-pki-ocsp-ui
Conflicts: redhat-pki-tks-theme
Conflicts: redhat-pki-tks-ui
+Conflicts: redhat-pki-ra-theme
+Conflicts: redhat-pki-ra-ui
+Conflicts: redhat-pki-tps-theme
+Conflicts: redhat-pki-tps-ui
# EPEL version of Dogtag "theme" ALWAYS replaces ALL versions of IPA "theme"
Obsoletes: ipa-pki-server-theme <= 9999
@@ -98,6 +102,10 @@ Obsoletes: dogtag-pki-ocsp-theme <= %{version}-%{release}
Obsoletes: dogtag-pki-ocsp-ui
Obsoletes: dogtag-pki-tks-theme <= %{version}-%{release}
Obsoletes: dogtag-pki-tks-ui
+Obsoletes: dogtag-pki-ra-theme <= %{version}-%{release}
+Obsoletes: dogtag-pki-ra-ui
+Obsoletes: dogtag-pki-tps-theme <= %{version}-%{release}
+Obsoletes: dogtag-pki-tps-ui
Provides: dogtag-pki-common-theme = %{version}-%{release}
Provides: pki-server-theme = %{version}-%{release}
@@ -120,61 +128,17 @@ Provides: dogtag-pki-tks-theme = %{version}-%{release}
Provides: pki-tks-theme = %{version}-%{release}
Provides: pki-tks-ui = %{version}-%{release}
-%description -n dogtag-pki-server-theme
-This PKI Server Framework User Interface contains
-the Dogtag textual and graphical user interface for the PKI Server Framework.
-
-This package is used by the Dogtag Certificate System.
-
-%{overview}
-
-
-%package -n dogtag-pki-ra-theme
-Summary: Certificate System - Registration Authority User Interface
-Group: System Environment/Base
-
-Requires: dogtag-pki-server-theme = %{version}-%{release}
-
-%if 0%{?rhel}
-# EPEL version of Dogtag "theme" conflicts with all versions of Red Hat "theme"
-Conflicts: redhat-pki-ra-theme
-Conflicts: redhat-pki-ra-ui
-%endif
-
-Obsoletes: dogtag-pki-ra-ui <= 9
-
+Provides: dogtag-pki-ra-theme = %{version}-%{release}
Provides: pki-ra-theme = %{version}-%{release}
Provides: pki-ra-ui = %{version}-%{release}
-%description -n dogtag-pki-ra-theme
-This Registration Authority (RA) User Interface contains
-the Dogtag textual and graphical user interface for the RA.
-
-This package is used by the Dogtag Certificate System.
-
-%{overview}
-
-
-%package -n dogtag-pki-tps-theme
-Summary: Certificate System - Token Processing System User Interface
-Group: System Environment/Base
-
-Requires: dogtag-pki-server-theme = %{version}-%{release}
-
-%if 0%{?rhel}
-# EPEL version of Dogtag "theme" conflicts with all versions of Red Hat "theme"
-Conflicts: redhat-pki-tps-theme
-Conflicts: redhat-pki-tps-ui
-%endif
-
-Obsoletes: dogtag-pki-tps-ui <= 9
-
+Provides: dogtag-pki-tps-theme = %{version}-%{release}
Provides: pki-tps-theme = %{version}-%{release}
Provides: pki-tps-ui = %{version}-%{release}
-%description -n dogtag-pki-tps-theme
-This Token Processing System (TPS) User Interface contains
-the Dogtag textual and graphical user interface for the TPS.
+%description -n dogtag-pki-server-theme
+This PKI Server Framework User Interface contains
+the Dogtag textual and graphical user interface for the PKI Server Framework.
This package is used by the Dogtag Certificate System.
@@ -233,8 +197,6 @@ cd build
cd build
%{__make} install DESTDIR=%{buildroot} INSTALL="install -p"
-chmod 755 %{buildroot}%{_datadir}/pki/tps-ui/cgi-bin/sow/cfg.pl
-
# NOTE: Several "theme" packages require ownership of the "/usr/share/pki"
# directory because the PKI subsystems (CA, DRM, OCSP, TKS, RA, TPS)
@@ -255,20 +217,6 @@ chmod 755 %{buildroot}%{_datadir}/pki/tps-ui/cgi-bin/sow/cfg.pl
%{_datadir}/pki/common-ui/
-%files -n dogtag-pki-ra-theme
-%defattr(-,root,root,-)
-%doc dogtag/ra-ui/LICENSE
-%dir %{_datadir}/pki
-%{_datadir}/pki/ra-ui/
-
-
-%files -n dogtag-pki-tps-theme
-%defattr(-,root,root,-)
-%doc dogtag/tps-ui/LICENSE
-%dir %{_datadir}/pki
-%{_datadir}/pki/tps-ui/
-
-
%files -n dogtag-pki-console-theme
%defattr(-,root,root,-)
%doc dogtag/console-ui/LICENSE
@@ -276,6 +224,9 @@ chmod 755 %{buildroot}%{_datadir}/pki/tps-ui/cgi-bin/sow/cfg.pl
%changelog
+* Wed Nov 21 2012 Endi S. Dewata <edewata@redhat.com> 10.0.0-0.9.b3
+- Removed Dogtag RA and TPS packages.
+
* Tue Nov 13 2012 Ade Lee <alee@redhat.com> 10.0.0-0.8.b3
- Added needed Requires for dogtag-pki-common-theme