summaryrefslogtreecommitdiffstats
path: root/daemons/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'daemons/Makefile.am')
-rw-r--r--daemons/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/daemons/Makefile.am b/daemons/Makefile.am
index 9960789a..7b2b9974 100644
--- a/daemons/Makefile.am
+++ b/daemons/Makefile.am
@@ -4,6 +4,14 @@ AUTOMAKE_OPTIONS = 1.7
NULL =
+AM_CFLAGS = $(NULL)
+if HAVE_GCC
+ AM_CFLAGS += -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith \
+ -Wcast-align -Werror-implicit-function-declaration \
+ $(NULL)
+endif
+export AM_CFLAGS
+
SUBDIRS = \
ipa-kpasswd \
ipa-slapi-plugins \