summaryrefslogtreecommitdiffstats
path: root/ipa-server/ipa-kpasswd/Makefile.am
diff options
context:
space:
mode:
authorRob Crittenden <rcritten@redhat.com>2008-01-18 16:20:36 -0500
committerRob Crittenden <rcritten@redhat.com>2008-01-18 16:20:36 -0500
commit042fb11fa107718a831d468d16188e02f6ae3712 (patch)
treee0e8ee6701800b8f03702cb338f8efa211b18046 /ipa-server/ipa-kpasswd/Makefile.am
parentaaa3cfd58ca0c62325d7637b67c6711660624f5d (diff)
downloadfreeipa-042fb11fa107718a831d468d16188e02f6ae3712.tar.gz
freeipa-042fb11fa107718a831d468d16188e02f6ae3712.tar.xz
freeipa-042fb11fa107718a831d468d16188e02f6ae3712.zip
Fix issues reported by rpmlint.
- Removing shebangs (#!) from a bunch of python libraries - Don't use a variable name in init scripts for the lock file - Keep the init script name consistent with the binary name, so renamed ipa-kpasswd.init to ipa_kpasswd.init - Add status option to the init scripts - Move most python scripts out of /usr/share/ipa and into the python site-packages directories (ipaserver and ipaclient) - Remove unnecessary sys.path.append("/usr/share/ipa") - Fix the license string in the spec files - Rename ipa-webgui to ipa_webgui everywhere - Fix a couple of issues reported by pychecker in ipa-python
Diffstat (limited to 'ipa-server/ipa-kpasswd/Makefile.am')
-rw-r--r--ipa-server/ipa-kpasswd/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/ipa-server/ipa-kpasswd/Makefile.am b/ipa-server/ipa-kpasswd/Makefile.am
index 02145d25..2953823c 100644
--- a/ipa-server/ipa-kpasswd/Makefile.am
+++ b/ipa-server/ipa-kpasswd/Makefile.am
@@ -28,7 +28,7 @@ ipa_kpasswd_LDADD = \
EXTRA_DIST = \
README \
- ipa-kpasswd.init \
+ ipa_kpasswd.init \
$(NULL)
MAINTAINERCLEANFILES = \
@@ -37,14 +37,14 @@ MAINTAINERCLEANFILES = \
initdir=$(sysconfdir)/rc.d/init.d
-install-data-hook: ipa-kpasswd.init
+install-data-hook: ipa_kpasswd.init
if test '!' -d $(DESTDIR)$(initdir); then \
$(mkinstalldirs) $(DESTDIR)$(initdir); \
chmod 755 $(DESTDIR)$(initdir); \
fi
- $(INSTALL_SCRIPT) $(srcdir)/ipa-kpasswd.init $(DESTDIR)$(initdir)/ipa-kpasswd
+ $(INSTALL_SCRIPT) $(srcdir)/ipa_kpasswd.init $(DESTDIR)$(initdir)/ipa_kpasswd
uninstall-hook:
- rm -f $(DESTDIR)$(initdir)/ipa-kpasswd
+ rm -f $(DESTDIR)$(initdir)/ipa_kpasswd