summaryrefslogtreecommitdiffstats
path: root/ipa-client/configure.ac
diff options
context:
space:
mode:
authorRob Crittenden <rcritten@redhat.com>2010-06-02 14:54:58 -0400
committerRob Crittenden <rcritten@redhat.com>2010-06-21 09:52:11 -0400
commitebab635250715e88ed2506a8043813cc9915936b (patch)
tree6574a0f2c53df853edea1ee91a870bb544e18d14 /ipa-client/configure.ac
parent31027c6183e3df927b08f0f0b7f84ae7420c3e88 (diff)
downloadfreeipa-ebab635250715e88ed2506a8043813cc9915936b.tar.gz
freeipa-ebab635250715e88ed2506a8043813cc9915936b.tar.xz
freeipa-ebab635250715e88ed2506a8043813cc9915936b.zip
Drop --with-openldap option in the client. This is no longer optional.
Diffstat (limited to 'ipa-client/configure.ac')
-rw-r--r--ipa-client/configure.ac68
1 files changed, 30 insertions, 38 deletions
diff --git a/ipa-client/configure.ac b/ipa-client/configure.ac
index c9d9e435..bed2e297 100644
--- a/ipa-client/configure.ac
+++ b/ipa-client/configure.ac
@@ -84,47 +84,39 @@ fi
AC_SUBST(KRB5_LIBS)
dnl ---------------------------------------------------------------------------
-dnl - Check for Mozilla LDAP or OpenLDAP SDK
-dnl ---------------------------------------------------------------------------
-
-AC_ARG_WITH(openldap, [ --with-openldap Use OpenLDAP])
-
-if test x$with_openldap = xyes; then
- AC_CHECK_LIB(ldap, ldap_search, with_ldap=yes)
- dnl Check for other libraries we need to link with to get the main routines.
- test "$with_ldap" != "yes" && { AC_CHECK_LIB(ldap, ldap_open, [with_ldap=yes with_ldap_lber=yes], , -llber) }
- test "$with_ldap" != "yes" && { AC_CHECK_LIB(ldap, ldap_open, [with_ldap=yes with_ldap_lber=yes with_ldap_krb=yes], , -llber -lkrb) }
- test "$with_ldap" != "yes" && { AC_CHECK_LIB(ldap, ldap_open, [with_ldap=yes with_ldap_lber=yes with_ldap_krb=yes with_ldap_des=yes], , -llber -lkrb -ldes) }
- dnl Recently, we need -lber even though the main routines are elsewhere,
- dnl because otherwise be get link errors w.r.t. ber_pvt_opt_on. So just
- dnl check for that (it's a variable not a fun but that doesn't seem to
- dnl matter in these checks) and stick in -lber if so. Can't hurt (even to
- dnl stick it in always shouldn't hurt, I don't think) ... #### Someone who
- dnl #### understands LDAP needs to fix this properly.
- test "$with_ldap_lber" != "yes" && { AC_CHECK_LIB(lber, ber_pvt_opt_on, with_ldap_lber=yes) }
-
- if test "$with_ldap" = "yes"; then
- if test "$with_ldap_des" = "yes" ; then
- OPENLDAP_LIBS="${OPENLDAP_LIBS} -ldes"
- fi
- if test "$with_ldap_krb" = "yes" ; then
- OPENLDAP_LIBS="${OPENLDAP_LIBS} -lkrb"
- fi
- if test "$with_ldap_lber" = "yes" ; then
- OPENLDAP_LIBS="${OPENLDAP_LIBS} -llber"
- fi
- OPENLDAP_LIBS="${OPENLDAP_LIBS} -lldap"
- else
- AC_MSG_ERROR([OpenLDAP not found])
- fi
-
- AC_SUBST(OPENLDAP_LIBS)
+dnl - OpenLDAP SDK
+dnl ---------------------------------------------------------------------------
+
+AC_CHECK_LIB(ldap, ldap_search, with_ldap=yes)
+dnl Check for other libraries we need to link with to get the main routines.
+test "$with_ldap" != "yes" && { AC_CHECK_LIB(ldap, ldap_open, [with_ldap=yes with_ldap_lber=yes], , -llber) }
+test "$with_ldap" != "yes" && { AC_CHECK_LIB(ldap, ldap_open, [with_ldap=yes with_ldap_lber=yes with_ldap_krb=yes], , -llber -lkrb) }
+test "$with_ldap" != "yes" && { AC_CHECK_LIB(ldap, ldap_open, [with_ldap=yes with_ldap_lber=yes with_ldap_krb=yes with_ldap_des=yes], , -llber -lkrb -ldes) }
+dnl Recently, we need -lber even though the main routines are elsewhere,
+dnl because otherwise be get link errors w.r.t. ber_pvt_opt_on. So just
+dnl check for that (it's a variable not a fun but that doesn't seem to
+dnl matter in these checks) and stick in -lber if so. Can't hurt (even to
+dnl stick it in always shouldn't hurt, I don't think) ... #### Someone who
+dnl #### understands LDAP needs to fix this properly.
+test "$with_ldap_lber" != "yes" && { AC_CHECK_LIB(lber, ber_pvt_opt_on, with_ldap_lber=yes) }
+
+if test "$with_ldap" = "yes"; then
+ if test "$with_ldap_des" = "yes" ; then
+ OPENLDAP_LIBS="${OPENLDAP_LIBS} -ldes"
+ fi
+ if test "$with_ldap_krb" = "yes" ; then
+ OPENLDAP_LIBS="${OPENLDAP_LIBS} -lkrb"
+ fi
+ if test "$with_ldap_lber" = "yes" ; then
+ OPENLDAP_LIBS="${OPENLDAP_LIBS} -llber"
+ fi
+ OPENLDAP_LIBS="${OPENLDAP_LIBS} -lldap"
else
- PKG_CHECK_MODULES(MOZLDAP, mozldap > 6)
- MOZLDAP_CFLAGS="${MOZLDAP_CFLAGS} -DWITH_MOZLDAP"
- AC_SUBST(MOZLDAP_CFLAGS)
+ AC_MSG_ERROR([OpenLDAP not found])
fi
+AC_SUBST(OPENLDAP_LIBS)
+
dnl ---------------------------------------------------------------------------
dnl - Check for POPT