summaryrefslogtreecommitdiffstats
path: root/ipa-client/configure.ac
diff options
context:
space:
mode:
authorRob Crittenden <rcritten@redhat.com>2010-10-26 15:14:05 -0400
committerRob Crittenden <rcritten@redhat.com>2010-10-26 15:39:43 -0400
commit9afedcb68315db2429656db0c89da47a669519e0 (patch)
tree5e6ce2ecda6651e33e55c56567310578f21828d1 /ipa-client/configure.ac
parent6abc4186b4f304e11bb6049d28e62f4abba92bc9 (diff)
downloadfreeipa-9afedcb68315db2429656db0c89da47a669519e0.tar.gz
freeipa-9afedcb68315db2429656db0c89da47a669519e0.tar.xz
freeipa-9afedcb68315db2429656db0c89da47a669519e0.zip
Error out when configure finds missing dependencies
ticket 315
Diffstat (limited to 'ipa-client/configure.ac')
-rw-r--r--ipa-client/configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/ipa-client/configure.ac b/ipa-client/configure.ac
index bed2e297..bfa77cef 100644
--- a/ipa-client/configure.ac
+++ b/ipa-client/configure.ac
@@ -26,7 +26,7 @@ dnl - Check for KRB5
dnl ---------------------------------------------------------------------------
KRB5_LIBS=
-AC_CHECK_HEADER(krb5.h)
+AC_CHECK_HEADER(krb5.h, [], [AC_MSG_ERROR([krb5.h not found])])
krb5_impl=mit
@@ -123,7 +123,7 @@ dnl - Check for POPT
dnl ---------------------------------------------------------------------------
POPT_LIBS=
-AC_CHECK_HEADER(popt.h)
+AC_CHECK_HEADER(popt.h, [], [AC_MSG_ERROR([popt.h not found])])
AC_CHECK_LIB(popt, poptGetContext, [POPT_LIBS="-lpopt"])
AC_SUBST(POPT_LIBS)
@@ -132,7 +132,7 @@ dnl - Check for SASL
dnl ---------------------------------------------------------------------------
SASL_LIBS=
-AC_CHECK_HEADER(sasl/sasl.h)
+AC_CHECK_HEADER(sasl/sasl.h, [], [AC_MSG_ERROR([sasl/sasl.h not found])])
AC_CHECK_LIB(sasl2, sasl_client_init, [SASL_LIBS="-lsasl2"])
AC_SUBST(SASL_LIBS)
@@ -153,7 +153,7 @@ dnl - Check for CURL
dnl ---------------------------------------------------------------------------
CURL_LIBS=
-AC_CHECK_HEADER(curl/curl.h)
+AC_CHECK_HEADER(curl/curl.h, [], [AC_MSG_ERROR([curl/curl.h not found])])
AC_CHECK_LIB(curl, curl_easy_init, [CURL_LIBS="-lcurl"])
if test "x$CURL_LIBS" = "x" ; then
AC_MSG_ERROR([curl not found])
@@ -165,7 +165,7 @@ dnl - Check for XMLRPC-C
dnl ---------------------------------------------------------------------------
XMLRPC_LIBS=
-AC_CHECK_HEADER(xmlrpc-c/base.h)
+AC_CHECK_HEADER(xmlrpc-c/base.h, [], [AC_MSG_ERROR([xmlrpc-c/base.h not found])])
AC_CHECK_LIB(xmlrpc_client, xmlrpc_client_init2, [XMLRPC_LIBS="-lxmlrpc -lxmlrpc_client -lxmlrpc_util"])
if test "x$XMLRPC_LIBS" = "x" ; then
AC_MSG_ERROR([xmlrpc-c not found])