summaryrefslogtreecommitdiffstats
path: root/ipa-client/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2010-11-04 19:29:01 +0100
committerSimo Sorce <ssorce@redhat.com>2010-11-22 16:01:35 -0500
commit3b7a86024b53fd0ac1a98e92bd93a170a1979aec (patch)
treec3fb64a3896c46f6822ac63d786320c0f7ec2e9b /ipa-client/Makefile.am
parentce75d1c6d6595bcb26dbacf7393098a8f9accb3f (diff)
downloadfreeipa-3b7a86024b53fd0ac1a98e92bd93a170a1979aec.tar.gz
freeipa-3b7a86024b53fd0ac1a98e92bd93a170a1979aec.tar.xz
freeipa-3b7a86024b53fd0ac1a98e92bd93a170a1979aec.zip
Use internal implementation of internal Kerberos functions
Don't use KRB5_PRIVATE. The patch implements and uses the following krb5 functions that are otherwise private in recent MIT Kerberos releases: * krb5_principal2salt_norealm * krb5_free_ktypes Signed-off-by: Simo Sorce <ssorce@redhat.com>
Diffstat (limited to 'ipa-client/Makefile.am')
-rw-r--r--ipa-client/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/ipa-client/Makefile.am b/ipa-client/Makefile.am
index 655a6866..ebb9a839 100644
--- a/ipa-client/Makefile.am
+++ b/ipa-client/Makefile.am
@@ -12,9 +12,13 @@ if HAVE_GCC
endif
export AM_CFLAGS
+KRB5_UTIL_DIR=../util
+KRB5_UTIL_SRCS=$(KRB5_UTIL_DIR)/ipa_krb5.c
+
INCLUDES = \
-I. \
-I$(srcdir) \
+ -I$(KRB5_UTIL_DIR) \
-DPREFIX=\""$(prefix)"\" \
-DBINDIR=\""$(bindir)"\" \
-DLIBDIR=\""$(libdir)"\" \
@@ -38,6 +42,7 @@ sbin_PROGRAMS = \
ipa_getkeytab_SOURCES = \
ipa-getkeytab.c \
+ $(KRB5_UTIL_SRCS) \
$(NULL)
ipa_getkeytab_LDADD = \