summaryrefslogtreecommitdiffstats
path: root/ipa-client/Makefile.am
diff options
context:
space:
mode:
authorKarl MacMillan <kmacmill@redhat.com>2007-10-17 15:46:39 -0400
committerKarl MacMillan <kmacmill@redhat.com>2007-10-17 15:46:39 -0400
commit1fcc3c66508e1e232768ae6a17396c2e44c669d0 (patch)
tree35df088d4eb319001418c81cc9f1752baa8c1306 /ipa-client/Makefile.am
parent31fb0033ba89304fbaa54e78f680960092b557ca (diff)
downloadfreeipa-1fcc3c66508e1e232768ae6a17396c2e44c669d0.tar.gz
freeipa-1fcc3c66508e1e232768ae6a17396c2e44c669d0.tar.xz
freeipa-1fcc3c66508e1e232768ae6a17396c2e44c669d0.zip
Autotool ipa-client - patch from William Jon McCann <mccann@jhu.edu>
Diffstat (limited to 'ipa-client/Makefile.am')
-rw-r--r--ipa-client/Makefile.am63
1 files changed, 63 insertions, 0 deletions
diff --git a/ipa-client/Makefile.am b/ipa-client/Makefile.am
new file mode 100644
index 00000000..caabffe1
--- /dev/null
+++ b/ipa-client/Makefile.am
@@ -0,0 +1,63 @@
+# This file will be processed with automake-1.7 to create Makefile.in
+
+AUTOMAKE_OPTIONS = 1.7
+
+NULL =
+
+SUBDIRS = \
+ firefox \
+ ipaclient \
+ ipa-install \
+ $(NULL)
+
+EXTRA_DIST = \
+ freeipa-client.spec \
+ COPYING \
+ AUTHORS \
+ INSTALL \
+ README \
+ HACKING \
+ NEWS \
+ ChangeLog \
+ $(NULL)
+
+DISTCLEANFILES = \
+ $(NULL)
+
+MAINTAINERCLEANFILES = \
+ *~ \
+ intltool-*.in \
+ compile \
+ configure \
+ INSTALL \
+ install-sh \
+ missing \
+ mkinstalldirs \
+ config.guess \
+ ltmain.sh \
+ config.sub \
+ depcomp \
+ Makefile.in \
+ config.h.* \
+ aclocal.m4 \
+ $(NULL)
+
+# Creating ChangeLog from hg log (taken from cairo/Makefile.am):
+
+ChangeLog: $(srcdir)/ChangeLog
+
+$(srcdir)/ChangeLog:
+ @if test -d "$(srcdir)/../.hg"; then \
+ (cd "$(srcdir)" && \
+ ./missing --run hg log --verbose) | fmt --split-only > $@.tmp \
+ && mv -f $@.tmp $@ \
+ || ($(RM) $@.tmp; \
+ echo Failed to generate ChangeLog, your ChangeLog may be outdated >&2; \
+ (test -f $@ || echo hg log is required to generate this file >> $@)); \
+ else \
+ test -f $@ || \
+ (echo A hg checkout and hg -log is required to generate ChangeLog >&2 && \
+ echo A hg checkout and hg log is required to generate this file >> $@); \
+ fi
+
+.PHONY: ChangeLog $(srcdir)/ChangeLog