summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNathan Kinder <nkinder@redhat.com>2007-02-09 23:28:19 +0000
committerNathan Kinder <nkinder@redhat.com>2007-02-09 23:28:19 +0000
commit2cbacc63087fc045f18b4dff451d7c98d4782f57 (patch)
treed19810022441d922502ec8c2e3d2b36aa19c9234 /configure.ac
parent941a7e89074e2ed0e0401aa778ccf412dce14fc8 (diff)
downloadds-2cbacc63087fc045f18b4dff451d7c98d4782f57.tar.gz
ds-2cbacc63087fc045f18b4dff451d7c98d4782f57.tar.xz
ds-2cbacc63087fc045f18b4dff451d7c98d4782f57.zip
Resolves: 228082
Summary: Added --enable-bundle option for legacy builds.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4426c0f2..a2f2fad9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,6 +59,19 @@ AC_ARG_ENABLE(debug, [ --enable-debug Enable debug features],
])
AC_SUBST([debug_defs])
+# Used for legacy style packaging where we bundle all of the dependencies.
+AC_MSG_CHECKING(for --enable-bundle)
+AC_ARG_ENABLE(bundle, [ --enable-bundle Enable bundled dependencies],
+[
+ AC_MSG_RESULT(yes)
+ bundle="1";
+],
+[
+ AC_MSG_RESULT(no)
+ bundle="";
+])
+AM_CONDITIONAL(BUNDLE,test "$bundle" = "1")
+
AC_PREFIX_DEFAULT([/opt/$PACKAGE_NAME])
# installation paths - by default, configure will just