summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorClark Williams <williams@redhat.com>2008-12-08 22:39:48 -0600
committerClark Williams <williams@redhat.com>2008-12-08 22:39:48 -0600
commit9038666d97fab3384326c78d84a7b5527e9ae8e1 (patch)
tree1aa6275c050bd0c8af59ba173aa9c50001d0ef30 /setup.py
parent7fe26b006d06342e672f163ccadda56feeadbc7e (diff)
downloadrteval-9038666d97fab3384326c78d84a7b5527e9ae8e1.tar.gz
rteval-9038666d97fab3384326c78d84a7b5527e9ae8e1.tar.xz
rteval-9038666d97fab3384326c78d84a7b5527e9ae8e1.zip
added imports
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py30
1 files changed, 30 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..72bca5e
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,30 @@
+#!/usr/bin/python
+from distutils.sysconfig import get_python_lib
+from distutils.core import setup
+from os.path import isfile, join
+import glob
+import os
+
+# Get PYTHONLIB with no prefix so --prefix installs work.
+PYTHONLIB = join(get_python_lib(standard_lib=1, prefix=''), 'site-packages')
+
+setup(name="prevert",
+ version = "0.1",
+ description = "PRE VErification for Real Time",
+ author = "Clark Williams",
+ author_email = "williams@redhat.com",
+ license = "GPLv2",
+ long_description =
+"""\
+The prevert (PRE Verification for Real Time) script is used to judge the
+behavior of a hardware platform while running a Realtime Linux kernel
+under a moderate to heavy load.
+
+Provides control logic for starting a system load and then running a
+response time measurement utility (cyclictest) for a specified amount
+of time. When the run is finished, the sample data from cyclictest is
+analyzed for standard statistical measurements (i.e mode, median, range,
+mean, variance and standard deviation) and a report is generated.
+""",
+ packages = ["prevert"],
+ )