summaryrefslogtreecommitdiffstats
path: root/service-win32/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'service-win32/Makefile.am')
-rw-r--r--service-win32/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/service-win32/Makefile.am b/service-win32/Makefile.am
new file mode 100644
index 0000000..97c5ef6
--- /dev/null
+++ b/service-win32/Makefile.am
@@ -0,0 +1,41 @@
+#
+# OpenVPN -- An application to securely tunnel IP networks
+# over a single UDP port, with support for SSL/TLS-based
+# session authentication and key exchange,
+# packet encryption, packet authentication, and
+# packet compression.
+#
+# Copyright (C) 2002-2005 OpenVPN Solutions LLC <info@openvpn.net>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License version 2
+# as published by the Free Software Foundation.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program (see the file COPYING included with this
+# distribution); if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+#
+
+MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
+
+if WIN32
+
+sbin_PROGRAMS = openvpnserv
+
+openvpnserv_SOURCES = \
+ openvpnserv.c \
+ service.h service.c
+
+else
+
+dist_noinst_DATA = \
+ openvpnserv.c \
+ service.h service.c
+
+endif