summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am95
1 files changed, 54 insertions, 41 deletions
diff --git a/Makefile.am b/Makefile.am
index 84a89c2..f8ce6f5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,18 +22,55 @@
# 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
#
+LDADD = @LIBOBJS@
+.PHONY: plugin
+
# This option prevents autoreconf from overriding our COPYING and
# INSTALL targets:
AUTOMAKE_OPTIONS = foreign
-sbin_PROGRAMS = openvpn
+MAINTAINERCLEANFILES = \
+ config.log config.status \
+ $(srcdir)/Makefile.in \
+ $(srcdir)/config.h.in $(srcdir)/config.h.in~ $(srcdir)/configure \
+ $(srcdir)/install-sh $(srcdir)/ltmain.sh $(srcdir)/missing \
+ $(srcdir)/depcomp $(srcdir)/aclocal.m4 \
+ $(srcdir)/config.guess $(srcdir)/config.sub \
+ $(srcdir)/config-win32.h $(srcdir)/openvpn.spec
+CLEANFILES = openvpn.8.html
-nodist_openvpn_SOURCES = config.h
+EXTRA_DIST = \
+ easy-rsa \
+ sample-config-files \
+ sample-keys \
+ sample-scripts \
+ suse \
+ tap-win32 \
+ contrib \
+ debug \
+ plugin
+
+SUBDIRS = \
+ images \
+ service-win32 \
+ install-win32
TESTS = t_lpback.sh t_cltsrv.sh
-dist_noinst_SCRIPTS = $(TESTS)
+sbin_PROGRAMS = openvpn
-.PHONY: plugin
+dist_noinst_HEADERS = \
+ config-win32.h
+
+dist_noinst_SCRIPTS = \
+ $(TESTS) \
+ doclean \
+ domake-win
+
+dist_noinst_DATA = \
+ openvpn.spec \
+ COPYRIGHT.GPL \
+ PORTS \
+ INSTALL-win32.txt
openvpn_SOURCES = \
base64.c base64.h \
@@ -80,6 +117,7 @@ openvpn_SOURCES = \
pool.c pool.h \
proto.c proto.h \
proxy.c proxy.h \
+ ieproxy.h ieproxy.c \
ps.c ps.h \
push.c push.h \
reliable.c reliable.h \
@@ -94,44 +132,19 @@ openvpn_SOURCES = \
status.c status.h \
syshead.h \
thread.c thread.h \
- tun.c tun.h
-
-LDADD = @LIBOBJS@
-
-man_MANS = openvpn.8
+ tun.c tun.h \
+ win32.h win32.c \
+ cryptoapi.h cryptoapi.c
-EXTRA_DIST = \
- doclean \
- $(man_MANS) \
- COPYRIGHT.GPL \
- PORTS \
- openvpn.spec \
- easy-rsa \
- sample-config-files \
- sample-keys \
- sample-scripts \
- gentoo \
- suse \
- openvpn.spec.in \
- config-win32.h \
- win32.h \
- win32.c \
- cryptoapi.h \
- cryptoapi.c \
- makefile.w32 \
- makefile.w32-vc \
- INSTALL-win32.txt \
- tap-win32 \
- install-win32 \
- service-win32 \
- contrib \
- debug \
- plugin \
- management \
- images \
- ieproxy.c \
- ieproxy.h \
- domake-win
dist-hook:
cd $(distdir) && for i in $(EXTRA_DIST) ; do find $$i -name .svn -type d -prune -exec rm -rf '{}' ';' ; rm -f `find $$i -type f | grep -E '(^|\/)\.?\#|\~$$|\.s?o$$'` ; done
+
+if WIN32
+dist_noinst_DATA += openvpn.8
+nodist_html_DATA = openvpn.8.html
+openvpn.8.html: $(srcdir)/openvpn.8
+ $(MAN2HTML) < $(srcdir)/openvpn.8 > openvpn.8.html
+else
+dist_man_MANS = openvpn.8
+endif