summaryrefslogtreecommitdiffstats
path: root/sample
diff options
context:
space:
mode:
authorSteffan Karger <steffan.karger@fox-it.com>2014-08-26 00:03:23 +0200
committerGert Doering <gert@greenie.muc.de>2014-11-14 15:03:21 +0100
commit6cb15b908a64b69b715fa8b2d60c71c6d9d3f9fc (patch)
tree6bf20802933b4689afecfc5165bd0674e25dd5d6 /sample
parent4e93e6dc88f4d904a4f2eb90140472a8d8fd68d0 (diff)
downloadopenvpn-6cb15b908a64b69b715fa8b2d60c71c6d9d3f9fc.zip
openvpn-6cb15b908a64b69b715fa8b2d60c71c6d9d3f9fc.tar.gz
openvpn-6cb15b908a64b69b715fa8b2d60c71c6d9d3f9fc.tar.xz
Add --tls-version-max
Because using TLS 1.2 breaks certain setups, a user might want to enforce a maximum TLS version to use. This patch adds that option. This patch removes a number of #ifdefs from ssl_polarssl.c, because the polarssl versions we currently support (polar 1.2 for openvpn 2.3, and polar 1.3 for openvpn-master) have all versions unconditionally enabled. Signed-off-by: Steffan Karger <steffan.karger@fox-it.com> Acked-by: Arne Schwabe <arne@rfc2549.org> Message-Id: <544EC052.3080809@fox-it.com> URL: http://article.gmane.org/gmane.network.openvpn.devel/9210 Signed-off-by: Gert Doering <gert@greenie.muc.de>
Diffstat (limited to 'sample')
0 files changed, 0 insertions, 0 deletions