summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSteffan Karger <steffan@karger.me>2014-06-22 20:18:39 +0200
committerGert Doering <gert@greenie.muc.de>2014-06-22 21:02:11 +0200
commitd0483476d047b4afc671e205bdfdb5b7f56ce48c (patch)
tree80efb56aa39a3661da642ffdb4f4da45c85b1445 /configure.ac
parent4978dadaed4ecf1b9dd256f57c6a5c895691580b (diff)
downloadopenvpn-d0483476d047b4afc671e205bdfdb5b7f56ce48c.tar.gz
openvpn-d0483476d047b4afc671e205bdfdb5b7f56ce48c.tar.xz
openvpn-d0483476d047b4afc671e205bdfdb5b7f56ce48c.zip
configure.ac: fix SSL_OP_NO_TICKET check
Only check for SSL_OP_NO_TICKET if building with --enable-ssl and using openssl. This fixes cross-compiling polarssl builds for Windows (where pkg-config would find the system openssl library, but the cross compiler would not have openssl for the target platform). Signed-off-by: Steffan Karger <steffan@karger.me> Acked-by: Gert Doering <gert@greenie.muc.de> Message-Id: <1403461119-21440-1-git-send-email-steffan@karger.me> URL: http://article.gmane.org/gmane.network.openvpn.devel/8795 Signed-off-by: Gert Doering <gert@greenie.muc.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1073312..77e950d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -800,7 +800,8 @@ if test "${have_openssl_crypto}" = "yes"; then
LIBS="${saved_LIBS}"
fi
-if test "${have_openssl_ssl}" = "yes"; then
+if test "${enable_ssl}" = "yes" && test "${with_crypto_library}" = "openssl";
+then
saved_CPPFLAGS="${CPPFLAGS}"
CPPFLAGS="${CPPFLAGS} ${OPENSSL_CRYPTO_CFLAGS}"
AC_MSG_CHECKING([for SSL_OP_NO_TICKET flag in OpenSSL])