summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGert Doering <gert@greenie.muc.de>2014-01-01 22:57:59 +0100
committerGert Doering <gert@greenie.muc.de>2014-01-06 12:22:12 +0100
commit4308f2374361f56b2049ccc5884cddd58d24b1e3 (patch)
treeb5271b38c716e03edfa0a7d23aa521fa1fce56e1 /configure.ac
parent40efb6359aff0e4805c0439acd6e899c687ef058 (diff)
downloadopenvpn-4308f2374361f56b2049ccc5884cddd58d24b1e3.tar.gz
openvpn-4308f2374361f56b2049ccc5884cddd58d24b1e3.tar.xz
openvpn-4308f2374361f56b2049ccc5884cddd58d24b1e3.zip
Provide LZ4 sources in src/compat/ and use if no system lz4 library found.
Bundle lz4.c and lz4.h from http://code.google.com/p/lz4/ (r109) as src/compat/compat-lz4.[ch], and use that (via #define NEED_COMPAT_LZ4) if autoconf cannot find lz4.h or -llz4 in the system. Signed-off-by: Gert Doering <gert@greenie.muc.de> Acked-by: Arne Schwabe <arne@rfc2549.org> Message-Id: <1388613479-22377-2-git-send-email-gert@greenie.muc.de> URL: http://article.gmane.org/gmane.network.openvpn.devel/8154
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 497dd44..636d4e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -970,8 +970,9 @@ if test "$enable_lz4" = "yes" && test "$enable_comp_stub" = "no"; then
])
if test $havelz4lib = 0 ; then
- AC_MSG_RESULT([LZ4 library available from http://code.google.com/p/lz4/])
- AC_MSG_ERROR([Or try ./configure --disable-lz4 OR ./configure --enable-comp-stub])
+ AC_MSG_RESULT([LZ4 library or header not found, using version in src/compat/compat-lz4.*])
+ AC_DEFINE([NEED_COMPAT_LZ4], [1], [use copy of LZ4 source in compat/])
+ LZ4_LIBS=""
fi
OPTIONAL_LZ4_CFLAGS="${LZ4_CFLAGS}"
OPTIONAL_LZ4_LIBS="${LZ4_LIBS}"