summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAlon Bar-Lev <alon.barlev@gmail.com>2012-02-29 22:12:08 +0200
committerDavid Sommerseth <davids@redhat.com>2012-03-22 22:17:27 +0100
commit0708426170fd578f598fb0f0d3df78bd1fca7117 (patch)
treeeac8b7e299ece852f9dea87be7f95287689385af /configure.ac
parent18b5fbdfb3aba63a62de197b4931cac77af2323c (diff)
downloadopenvpn-0708426170fd578f598fb0f0d3df78bd1fca7117.tar.gz
openvpn-0708426170fd578f598fb0f0d3df78bd1fca7117.tar.xz
openvpn-0708426170fd578f598fb0f0d3df78bd1fca7117.zip
build: properly process lzo-stub
Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com> Acked-by: Samuli Seppänen <samuli@openvpn.net> Signed-off-by: David Sommerseth <davids@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index baa66b2..da41554 100644
--- a/configure.ac
+++ b/configure.ac
@@ -701,11 +701,6 @@ if test "${enable_lzo}" = "yes" && test "${enable_lzo_stub}" = "no"; then
fi
fi
-dnl enable multi-client mode
-if test "${enable_lzo_stub}" = "yes"; then
- AC_DEFINE([LZO_STUB], [1], [Enable LZO stub capability])
-fi
-
PKG_CHECK_MODULES(
[PKCS11_HELPER],
[libpkcs11-helper-1 >= 1.02],
@@ -867,6 +862,13 @@ if test "${enable_selinux}" = "yes"; then
AC_DEFINE([ENABLE_SELINUX], [1], [SELinux support])
fi
+if test "${enable_lzo_stub}" = "yes"; then
+ test "${enable_lzo}" = "yes" && AC_MSG_ERROR([Cannot have both lzo stub and lzo enabled])
+ AC_DEFINE([ENABLE_LZO_STUB], [1], [Enable LZO stub capability])
+ AC_DEFINE([USE_LZO], [1], [Enable LZO compression library])
+ AC_DEFINE([LZO_VERSION_NUM], ["STUB"], [LZO version number])
+fi
+
if test "${enable_pkcs11}" = "yes"; then
test "${have_pkcs11_helper}" != "yes" && AC_MSG_ERROR([PKCS11 enabled but libpkcs11-helper is missing])
test "${enable_ssl}" != "yes" && AC_MSG_ERROR([PKCS11 can be enabled only if SSL is enabled])