summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorjames <james@e7ae566f-a301-0410-adde-c780ea21d3b5>2005-10-15 12:14:56 +0000
committerjames <james@e7ae566f-a301-0410-adde-c780ea21d3b5>2005-10-15 12:14:56 +0000
commitbe38c0514aabcff8b4a0b588a06d36c150c8b5ed (patch)
treeeb8f07b55de462c2789a9e2138a19ad6e321b0d7 /configure.ac
parentc7e014dda9d704b7df6ff37a688d5395649b356a (diff)
downloadopenvpn-be38c0514aabcff8b4a0b588a06d36c150c8b5ed.tar.gz
openvpn-be38c0514aabcff8b4a0b588a06d36c150c8b5ed.tar.xz
openvpn-be38c0514aabcff8b4a0b588a06d36c150c8b5ed.zip
Fixed some minor build issues with PKCS11 patch:
"make dist" wasn't building correct tarball. Some ./configure --enable/--disable options were broken. Renamed pkcs11 directory to pkcs11-headers to work around automake issue. git-svn-id: http://svn.openvpn.net/projects/openvpn/branches/BETA21/openvpn@626 e7ae566f-a301-0410-adde-c780ea21d3b5
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 844778f..6b01f37 100644
--- a/configure.ac
+++ b/configure.ac
@@ -466,7 +466,7 @@ fi
dnl
dnl Check for dlopen -- first try libc then libdl.
dnl
-if test "$PLUGINS" = "yes"; then
+if test "$PLUGINS" = "yes" || test "$PKCS11" = "yes"; then
AC_CHECKING([for libdl Library and Header files])
AC_CHECK_HEADER(dlfcn.h,
[AC_CHECK_FUNC(dlopen,
@@ -603,7 +603,7 @@ fi
dnl enable pkcs11 capability
if test "$PKCS11" = "yes"; then
- AC_DEFINE(ENABLE_PKCS11, 1, [Enable PKCS#11 capability])
+ AC_DEFINE(USE_PKCS11, 1, [Enable PKCS11 capability])
fi
dnl enable socks