summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGert Doering <gert@greenie.muc.de>2010-07-10 11:24:41 +0200
committerDavid Sommerseth <dazo@users.sourceforge.net>2010-10-21 11:40:36 +0200
commita9b5134f78480f903434366478f3918c021b7caa (patch)
treea058fa2ec9ea36ac40c736fd26fc6e3d9797a521 /configure.ac
parent22ff667e4e7e412db21d9b1642fc92fa670d323d (diff)
downloadopenvpn-a9b5134f78480f903434366478f3918c021b7caa.tar.gz
openvpn-a9b5134f78480f903434366478f3918c021b7caa.tar.xz
openvpn-a9b5134f78480f903434366478f3918c021b7caa.zip
Fix <net/if.h> compile time problems on OpenBSD for good
Previous fix (commit eb973e055bc249948) fixed NetBSD but not OpenBSD (include <sys/socket.h> *after* <sys/types.h>) Signed-off-by: Gert Doering <gert@greenie.muc.de> Acked-by: krzee <jeff@doeshosting.com> Signed-off-by: David Sommerseth <dazo@users.sourceforge.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index b91a41c..c817938 100644
--- a/configure.ac
+++ b/configure.ac
@@ -368,12 +368,12 @@ if test "${WIN32}" != "yes"; then
linux/types.h sys/poll.h sys/epoll.h err.h dnl
)
AC_CHECK_HEADERS(net/if.h,,,
- [#ifdef HAVE_SYS_SOCKET_H
- # include <sys/socket.h>
- #endif
- #ifdef HAVE_SYS_TYPES_H
+ [#ifdef HAVE_SYS_TYPES_H
# include <sys/types.h>
#endif
+ #ifdef HAVE_SYS_SOCKET_H
+ # include <sys/socket.h>
+ #endif
])
AC_CHECK_HEADERS(netinet/ip.h,,,
[#ifdef HAVE_SYS_TYPES_H