summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorjames <james@e7ae566f-a301-0410-adde-c780ea21d3b5>2007-04-21 17:59:40 +0000
committerjames <james@e7ae566f-a301-0410-adde-c780ea21d3b5>2007-04-21 17:59:40 +0000
commit8d54351056d6c267eb4c0266a1de8b68cb7b92f0 (patch)
treea9a26b1ebea190835595031963f6fb94549a2772 /configure.ac
parent7e90ca24c05c5b8fb35a1aff78291125d5d7150b (diff)
downloadopenvpn-8d54351056d6c267eb4c0266a1de8b68cb7b92f0.tar.gz
openvpn-8d54351056d6c267eb4c0266a1de8b68cb7b92f0.tar.xz
openvpn-8d54351056d6c267eb4c0266a1de8b68cb7b92f0.zip
Clean up configure on FreeBSD for recent autotool versions that
require that all .h files have to be compiled. Also, FreeBSD install does not support GNU long options which the Makefile in easy-rsa/2.0 uses (not checked the others as we don't install those on Gentoo) -- Roy Marples git-svn-id: http://svn.openvpn.net/projects/openvpn/branches/BETA21/openvpn@1861 e7ae566f-a301-0410-adde-c780ea21d3b5
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 35 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c443f68..4d1e2ec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -284,12 +284,44 @@ AC_CHECK_HEADERS(sys/time.h sys/socket.h sys/ioctl.h sys/stat.h dnl
sys/mman.h fcntl.h sys/file.h stdlib.h stdint.h dnl
stdarg.h unistd.h signal.h stdio.h string.h dnl
strings.h ctype.h errno.h syslog.h pwd.h grp.h dnl
- net/if_tun.h net/if.h stropts.h sys/sockio.h dnl
- netinet/in.h netinet/in_systm.h netinet/ip.h dnl
- netinet/if_ether.h netinet/tcp.h resolv.h arpa/inet.h dnl
+ net/if_tun.h stropts.h sys/sockio.h dnl
+ netinet/in.h netinet/in_systm.h dnl
+ netinet/tcp.h arpa/inet.h dnl
netdb.h sys/uio.h linux/if_tun.h linux/sockios.h dnl
linux/types.h sys/poll.h sys/epoll.h err.h dnl
)
+AC_CHECK_HEADERS(net/if.h,,,
+ [#ifdef HAVE_SYS_SOCKET_H
+ # include <sys/socket.h>
+ #endif
+ ])
+AC_CHECK_HEADERS(netinet/ip.h,,,
+ [#ifdef HAVE_SYS_TYPES_H
+ # include <sys/types.h>
+ #endif
+ #ifdef HAVE_NETINET_IN_H
+ # include <netinet/in.h>
+ #endif
+ #ifdef HAVE_NETINET_IN_SYSTM_H
+ # include <netinet/in_systm.h>
+ #endif
+ ])
+AC_CHECK_HEADERS(netinet/if_ether.h,,,
+ [#ifdef HAVE_SYS_TYPES_H
+ # include <sys/types.h>
+ #endif
+ #ifdef HAVE_SYS_SOCKET_H
+ # include <sys/socket.h>
+ #endif
+ #ifdef HAVE_NETINET_IN_H
+ # include <netinet/in.h>
+ #endif
+ ])
+AC_CHECK_HEADERS(resolv.h,,,
+ [#ifdef HAVE_NETINET_IN_H
+ # include <netinet/in.h>
+ #endif
+ ])
AC_CHECK_HEADERS(linux/errqueue.h,,,
[#ifdef HAVE_LINUX_TYPES_H
# include <linux/types.h>