summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2010-02-15 23:15:44 +0100
committerDavid Sommerseth <dazo@users.sourceforge.net>2010-10-21 21:10:05 +0200
commit0c1f7ad5e84e7a79bd3f982cba5dad3cc12dbebb (patch)
tree512bcf381915a374a00dcfce4e19eda7a277cb46 /configure.ac
parent59afc4a5f72e22b850cfa2845385172623a38e77 (diff)
downloadopenvpn-0c1f7ad5e84e7a79bd3f982cba5dad3cc12dbebb.tar.gz
openvpn-0c1f7ad5e84e7a79bd3f982cba5dad3cc12dbebb.tar.xz
openvpn-0c1f7ad5e84e7a79bd3f982cba5dad3cc12dbebb.zip
Reworked the eurephia patch for inclusion to the openvpn-testing tree
Addedd configure option (--disable-eurephia) to disable the code which the eurephia plug-in depends on. It was chosen to use --disable-eurephia, as this patch is not much intrusive. It just enables a SHA1 fingerprint environment variable for each certificate being used for the connection. Signed-off-by: David Sommerseth <dazo@users.sourceforge.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4777108..aca812f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -98,6 +98,12 @@ AC_ARG_ENABLE(plugins,
[PLUGINS="yes"]
)
+AC_ARG_ENABLE(eurephia,
+ [ --disable-eurephia Disable support for the eurephia plug-in],
+ [EUREPHIA="$enableval"],
+ [EUREPHIA="yes"]
+)
+
AC_ARG_ENABLE(management,
[ --disable-management Disable management server support],
[MANAGEMENT="$enableval"],
@@ -641,6 +647,9 @@ if test "${WIN32}" != "yes"; then
)],
[AC_MSG_RESULT([libdl headers not found.])]
)
+ if test "$EUREPHIA" = "yes"; then
+ AC_DEFINE(ENABLE_EUREPHIA, 1, [Enable support for the eurephia plug-in])
+ fi
fi
fi