summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorjames <james@e7ae566f-a301-0410-adde-c780ea21d3b5>2005-10-13 08:38:41 +0000
committerjames <james@e7ae566f-a301-0410-adde-c780ea21d3b5>2005-10-13 08:38:41 +0000
commitce98fd24bd72d479805cb121ca8e118826f1ed76 (patch)
treeb109113870455d2c5595a0833301f234353578e3 /configure.ac
parentcecc5e657bb38c03f80747eab40073bc6ded9631 (diff)
downloadopenvpn-ce98fd24bd72d479805cb121ca8e118826f1ed76.tar.gz
openvpn-ce98fd24bd72d479805cb121ca8e118826f1ed76.tar.xz
openvpn-ce98fd24bd72d479805cb121ca8e118826f1ed76.zip
Merged PKCS#11 patch.
Pre-2.1_beta3 git-svn-id: http://svn.openvpn.net/projects/openvpn/branches/BETA21/openvpn@604 e7ae566f-a301-0410-adde-c780ea21d3b5
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f7cf49f..9faae97 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,7 +25,7 @@ dnl Process this file with autoconf to produce a configure script.
AC_PREREQ(2.50)
-AC_INIT([OpenVPN], [2.1_beta2], [openvpn-users@lists.sourceforge.net], [openvpn])
+AC_INIT([OpenVPN], [2.1_beta3], [openvpn-users@lists.sourceforge.net], [openvpn])
AM_CONFIG_HEADER(config.h)
AC_CONFIG_SRCDIR(syshead.h)
@@ -71,6 +71,12 @@ AC_ARG_ENABLE(management,
[MANAGEMENT="yes"]
)
+AC_ARG_ENABLE(pkcs11,
+ [ --disable-pkcs11 Disable pkcs11 support],
+ [PKCS11="$enableval"],
+ [PKCS11="yes"]
+)
+
AC_ARG_ENABLE(socks,
[ --disable-socks Disable Socks support],
[SOCKS="$enableval"],
@@ -584,6 +590,11 @@ if test "$MANAGEMENT" = "yes"; then
AC_DEFINE(ENABLE_MANAGEMENT, 1, [Enable management server capability])
fi
+dnl enable pkcs11 capability
+if test "$PKCS11" = "yes"; then
+ AC_DEFINE(ENABLE_PKCS11, 1, [Enable PKCS#11 capability])
+fi
+
dnl enable socks
if test "$SOCKS" = "yes"; then
AC_DEFINE(ENABLE_SOCKS, 1, [Enable Socks proxy support])