summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Sommerseth <davids@redhat.com>2011-12-08 00:40:45 +0100
committerDavid Sommerseth <davids@redhat.com>2012-01-10 19:38:35 +0100
commitec302f7061b7ab4dd21bdac77dd115e75b50cbc0 (patch)
treee55a9cccd3446f94f86e505259aad7b890bae0e5 /configure.ac
parent8ee5646111625c598efbc82413649b1ab6275877 (diff)
downloadopenvpn-ec302f7061b7ab4dd21bdac77dd115e75b50cbc0.tar.gz
openvpn-ec302f7061b7ab4dd21bdac77dd115e75b50cbc0.tar.xz
openvpn-ec302f7061b7ab4dd21bdac77dd115e75b50cbc0.zip
Move away from openvpn_basename() over to platform provided basename()
This kicks out the openvpn_basename() function from misc.[ch] and puts glibc equivalents into compat.[ch]. This is to provide the same functionality on platforms not having a native basename() function available. In addition this patch adds dirname() which commit 0f2bc0dd92f43c91e depends. Without dirname(), openvpn won't build in Visual Studio. v2: Move all functions from compat.h to compat.c v3: Use glibc versions of basename() and dirname() instead Signed-off-by: David Sommerseth <davids@redhat.com> Acked-by: Alon Bar-Lev <alon.barlev@gmail.com> URL: http://thread.gmane.org/gmane.network.openvpn.devel/5178/focus=5215
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7143cc5..d147d38 100644
--- a/configure.ac
+++ b/configure.ac
@@ -521,7 +521,7 @@ AC_CHECK_FUNCS(daemon chroot getpwnam setuid nice system getpid dup dup2 dnl
getpass strerror syslog openlog mlockall getgrnam setgid dnl
setgroups stat flock readv writev time dnl
setsid chdir putenv getpeername unlink dnl
- chsize ftruncate execve getpeereid umask)
+ chsize ftruncate execve getpeereid umask basename dirname)
# Windows use stdcall for winsock so we cannot auto detect these
m4_define([SOCKET_FUNCS], [socket recv recvfrom send sendto listen dnl