summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAlon Bar-Lev <alon.barlev@gmail.com>2012-04-08 22:21:47 +0300
committerDavid Sommerseth <davids@redhat.com>2012-04-26 20:04:55 +0200
commit88f3a4026c48e92bf3ce18d7611b7b88f7bed0be (patch)
tree0c2684da6771032776971a0866f7999abf71576b /configure.ac
parent4025a59575a9a90cb96fde01eba8db3c1cab0b2b (diff)
downloadopenvpn-88f3a4026c48e92bf3ce18d7611b7b88f7bed0be.tar.gz
openvpn-88f3a4026c48e92bf3ce18d7611b7b88f7bed0be.tar.xz
openvpn-88f3a4026c48e92bf3ce18d7611b7b88f7bed0be.zip
build: properly detect TUNSETPERSIST
Do not rely on system symbol throught sources but on autoconf detection. Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com> Acked-by: David Sommerseth <davids@redhat.com> Signed-off-by: David Sommerseth <davids@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1f32c9d..773fa4b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -598,6 +598,16 @@ AC_CHECK_HEADERS(
],
[have_tap_header="yes"]
)
+AC_CHECK_DECLS(
+ [TUNSETPERSIST],
+ [AC_DEFINE([ENABLE_FEATURE_TUN_PERSIST], [1], [We have persist tun capability])],
+ ,
+ [[
+ #ifdef HAVE_LINUX_IF_TUN_H
+ #include <linux/if_tun.h>
+ #endif
+ ]]
+)
CFLAGS="${old_CFLAGS}"
test "${have_tap_header}" = "yes" || AC_MSG_ERROR([no tap header could be found])