summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2010-08-28 20:14:36 +0200
committerDavid Sommerseth <dazo@users.sourceforge.net>2010-11-14 22:05:45 +0100
commit7aa6c12a4424d00ea0add0a849f8a5b31a2de6a1 (patch)
treea7bd2aef0c2cccaa79ad6a99785fd4f1d606fcd7 /Makefile.am
parent5682d3394204c788988b3cf67b3443a717704d2c (diff)
downloadopenvpn-7aa6c12a4424d00ea0add0a849f8a5b31a2de6a1.tar.gz
openvpn-7aa6c12a4424d00ea0add0a849f8a5b31a2de6a1.tar.xz
openvpn-7aa6c12a4424d00ea0add0a849f8a5b31a2de6a1.zip
Clean-up: Remove pthread and mutex locking code
This code was not activated at all, and hard coded as disabled in syshead.h with this code snippet: /* * Pthread support is currently experimental (and quite unfinished). */ #if 1 /* JYFIXME -- if defined, disable pthread */ #undef USE_PTHREAD #endif So no matter if --enable-pthread when running ./configure or not, this feature was never enabled in reality. Further, by removing the blocker code above made OpenVPN uncompilable in the current state. As the threading part needs to be completely rewritten and pthreading will not be supported in OpenVPN 2.x, removing this code seems most reasonable. In addition, a lot of mutex locking code was also removed, as they were practically NOP functions, due to pthreading being forcefully disabled Signed-off-by: David Sommerseth <dazo@users.sourceforge.net> Acked-by: James Yonan <james@openvpn.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 76573d1..c7b91c8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -137,7 +137,6 @@ openvpn_SOURCES = \
ssl.c ssl.h \
status.c status.h \
syshead.h \
- thread.c thread.h \
tun.c tun.h \
win32.h win32.c \
cryptoapi.h cryptoapi.c