summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAdriaan de Jong <dejong@fox-it.com>2011-07-01 14:15:11 +0200
committerDavid Sommerseth <davids@redhat.com>2011-10-22 14:35:16 +0200
commit53f97e1e9125aa9327c7ecf4a1b0b1a0c20cf2de (patch)
treedb6651657f923cf0e7f2a6c34fd673ccb2e5c2fb /Makefile.am
parent725336282db0c9f160d6ef577288e5a628959776 (diff)
downloadopenvpn-53f97e1e9125aa9327c7ecf4a1b0b1a0c20cf2de.tar.gz
openvpn-53f97e1e9125aa9327c7ecf4a1b0b1a0c20cf2de.tar.xz
openvpn-53f97e1e9125aa9327c7ecf4a1b0b1a0c20cf2de.zip
Added PolarSSL support:
- Crypto library - SSL library - PKCS#11 support For missing features, please see README.polarssl Signed-off-by: Adriaan de Jong <dejong@fox-it.com> Acked-by: James Yonan <james@openvpn.net> Acked-by: Gert Doering <gert@greenie.muc.de> Signed-off-by: David Sommerseth <davids@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0108d8f..3228798 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -160,6 +160,13 @@ openvpn_SOURCES += \
ssl_openssl.c ssl_openssl.h \
ssl_verify_openssl.c ssl_verify_openssl.h
endif
+if USE_POLARSSL
+openvpn_SOURCES += \
+ crypto_polarssl.c crypto_polarssl.h \
+ pkcs11_polarssl.c \
+ ssl_polarssl.c ssl_polarssl.h \
+ ssl_verify_polarssl.c ssl_verify_polarssl.h
+endif
dist-hook:
cd $(distdir) && for i in $(EXTRA_DIST) $(SUBDIRS) ; do find $$i -name .svn -type d -prune -exec rm -rf '{}' ';' ; rm -f `find $$i -type f | grep -E '(^|\/)\.?\#|\~$$|\.s?o$$'` ; done