summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2010-04-22 23:01:31 +0200
committerDavid Sommerseth <dazo@users.sourceforge.net>2010-10-21 21:21:05 +0200
commit043b61b2a5a30d5d45b15e9f8de7b72052225727 (patch)
tree1d26b19fdd7667d8ea088d00267f5d2396172037 /Makefile.am
parentd94049b8284cdddd90fc17cc171fbf20fcc12780 (diff)
downloadopenvpn-043b61b2a5a30d5d45b15e9f8de7b72052225727.tar.gz
openvpn-043b61b2a5a30d5d45b15e9f8de7b72052225727.tar.xz
openvpn-043b61b2a5a30d5d45b15e9f8de7b72052225727.zip
Fix dependency checking for configure.h (v2)
Alon Bar-Lev indicated commit f27bf509315a48b0070294c3993a718df0c2626c was missing proper dependency checking. This patch corrects this and fixes an issue when creating configure.h via make distcheck. This is an enhanced version of the one sent to the openvpn-devel mailing list April 13, 2010 [1], after having received some feedback from Gert Doering, cleaning up configure_log.awk further. [1] <http://thread.gmane.org/gmane.network.openvpn.devel/3410/focus=3491> Signed-off-by: David Sommerseth <dazo@users.sourceforge.net> Acked-by: Gert Doering <gert@greenie.muc.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 3b858e2..fdc9def 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,7 +66,8 @@ dist_noinst_SCRIPTS = \
$(TESTS) \
doclean \
domake-win \
- t_cltsrv-down.sh
+ t_cltsrv-down.sh \
+ configure_h.awk configure_log.awk
dist_noinst_DATA = \
openvpn.spec \
@@ -142,9 +143,12 @@ openvpn_SOURCES = \
win32.h win32.c \
cryptoapi.h cryptoapi.c
+nodist_openvpn_SOURCES = configure.h
+options.$(OBJEXT): configure.h
+
configure.h: Makefile
- awk -f configure_h.awk config.h > $@
- awk -f configure_log.awk config.log >> $@
+ awk -f $(srcdir)/configure_h.awk config.h > $@
+ awk -f $(srcdir)/configure_log.awk config.log >> $@
clean-local:
-rm -f configure.h