summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAdriaan de Jong <dejong@fox-it.com>2011-06-22 17:16:03 +0200
committerDavid Sommerseth <davids@redhat.com>2011-10-19 22:05:44 +0200
commit6825182b8137c036afcdc0e48397c0ea5ffc2404 (patch)
treeb65554fcab08105f5d8ad2866270c7630ee366d1 /Makefile.am
parent0a18017472edb52c5535bc814c2aceaa2b562222 (diff)
downloadopenvpn-6825182b8137c036afcdc0e48397c0ea5ffc2404.tar.gz
openvpn-6825182b8137c036afcdc0e48397c0ea5ffc2404.tar.xz
openvpn-6825182b8137c036afcdc0e48397c0ea5ffc2404.zip
Refactored to rand_bytes for OpenSSL-independency
Signed-off-by: Adriaan de Jong <dejong@fox-it.com> Acked-by: David Sommerseth <davids@redhat.com> Signed-off-by: David Sommerseth <davids@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 266a5af..ca56ae3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -85,7 +85,7 @@ openvpn_SOURCES = \
clinat.c clinat.h \
common.h \
config-win32.h \
- crypto.c crypto.h \
+ crypto.c crypto.h crypto_backend.h \
dhcp.c dhcp.h \
errlevel.h \
error.c error.h \
@@ -152,6 +152,11 @@ configure.h: Makefile
awk -f $(srcdir)/configure_h.awk config.h > $@
awk -f $(srcdir)/configure_log.awk config.log >> $@
+if USE_OPENSSL
+openvpn_SOURCES += \
+ crypto_openssl.c crypto_openssl.h
+endif
+
dist-hook:
cd $(distdir) && for i in $(EXTRA_DIST) $(SUBDIRS) ; do find $$i -name .svn -type d -prune -exec rm -rf '{}' ';' ; rm -f `find $$i -type f | grep -E '(^|\/)\.?\#|\~$$|\.s?o$$'` ; done