summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2010-04-13 15:12:27 +0200
committerDavid Sommerseth <dazo@users.sourceforge.net>2010-10-21 21:22:26 +0200
commit3ee62caf112c1e8c9a79079b0cb0648446915caa (patch)
tree629a0c43db68b541ecd5bd64150f93d4a4e66619 /Makefile.am
parent043b61b2a5a30d5d45b15e9f8de7b72052225727 (diff)
downloadopenvpn-3ee62caf112c1e8c9a79079b0cb0648446915caa.tar.gz
openvpn-3ee62caf112c1e8c9a79079b0cb0648446915caa.tar.xz
openvpn-3ee62caf112c1e8c9a79079b0cb0648446915caa.zip
Make use of automake CLEANFILES variable instead of clean-local rule
Signed-off-by: David Sommerseth <dazo@users.sourceforge.net> Acked-by: Gert Doering <gert@greenie.muc.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 1 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index fdc9def..430d3ab 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -38,7 +38,7 @@ MAINTAINERCLEANFILES = \
$(srcdir)/depcomp $(srcdir)/aclocal.m4 \
$(srcdir)/config.guess $(srcdir)/config.sub \
$(srcdir)/openvpn.spec
-CLEANFILES = openvpn.8.html
+CLEANFILES = openvpn.8.html configure.h
EXTRA_DIST = \
easy-rsa \
@@ -150,9 +150,6 @@ configure.h: Makefile
awk -f $(srcdir)/configure_h.awk config.h > $@
awk -f $(srcdir)/configure_log.awk config.log >> $@
-clean-local:
- -rm -f configure.h
-
dist-hook:
cd $(distdir) && for i in $(EXTRA_DIST) $(SUBDIRS) ; do find $$i -name .svn -type d -prune -exec rm -rf '{}' ';' ; rm -f `find $$i -type f | grep -E '(^|\/)\.?\#|\~$$|\.s?o$$'` ; done