summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2010-07-22 22:33:16 +0200
committerDavid Sommerseth <dazo@users.sourceforge.net>2010-07-22 22:33:16 +0200
commit0b026a985d6232d459ed4e2b6642853c959667da (patch)
treea43bbe677b158de41f32bb240358ec4c1d2f34b2 /Makefile.am
parentc70135d8ed31d133f2fb085bee01db8ad26d7fec (diff)
parent031d18fcb8a2a552aecabb41f1afdfe3f51bdd58 (diff)
downloadopenvpn-0b026a985d6232d459ed4e2b6642853c959667da.tar.gz
openvpn-0b026a985d6232d459ed4e2b6642853c959667da.tar.xz
openvpn-0b026a985d6232d459ed4e2b6642853c959667da.zip
Merge branch 'feat_misc' into beta2.2
Conflicts: Makefile.am - Copyright update - Added configure.h to CLEANFILES options.c - Copyright update - More verbose information about enabled features Signed-off-by: David Sommerseth <dazo@users.sourceforge.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 2980dac..75f9b1a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,6 +6,7 @@
# packet compression.
#
# Copyright (C) 2002-2010 OpenVPN Technologies, Inc. <sales@openvpn.net>
+# Copyright (C) 2010 David Sommerseth <dazo@users.sourceforge.net>
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License version 2
@@ -37,7 +38,7 @@ MAINTAINERCLEANFILES = \
$(srcdir)/depcomp $(srcdir)/aclocal.m4 \
$(srcdir)/config.guess $(srcdir)/config.sub \
$(srcdir)/openvpn.spec
-CLEANFILES = openvpn.8.html
+CLEANFILES = openvpn.8.html configure.h
EXTRA_DIST = \
easy-rsa \
@@ -64,7 +65,8 @@ dist_noinst_SCRIPTS = \
$(TESTS) \
doclean \
domake-win \
- t_cltsrv-down.sh
+ t_cltsrv-down.sh \
+ configure_h.awk configure_log.awk
dist_noinst_DATA = \
openvpn.spec \
@@ -140,6 +142,12 @@ openvpn_SOURCES = \
win32.h win32.c \
cryptoapi.h cryptoapi.c
+nodist_openvpn_SOURCES = configure.h
+options.$(OBJEXT): configure.h
+
+configure.h: Makefile
+ awk -f $(srcdir)/configure_h.awk config.h > $@
+ awk -f $(srcdir)/configure_log.awk config.log >> $@
dist-hook:
cd $(distdir) && for i in $(EXTRA_DIST) $(SUBDIRS) ; do find $$i -name .svn -type d -prune -exec rm -rf '{}' ';' ; rm -f `find $$i -type f | grep -E '(^|\/)\.?\#|\~$$|\.s?o$$'` ; done