summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Sommerseth <dazo@users.sourceforge.net>2010-04-22 23:01:31 +0200
committerDavid Sommerseth <dazo@users.sourceforge.net>2010-04-22 23:01:31 +0200
commit63c367398a57c98ab56f8532e3ff3ea8b89ab92e (patch)
tree0066c5c36391a2e24b32ade756e634592c792ddc /Makefile.am
parentf27bf509315a48b0070294c3993a718df0c2626c (diff)
downloadopenvpn-63c367398a57c98ab56f8532e3ff3ea8b89ab92e.tar.gz
openvpn-63c367398a57c98ab56f8532e3ff3ea8b89ab92e.tar.xz
openvpn-63c367398a57c98ab56f8532e3ff3ea8b89ab92e.zip
Fix dependency checking for configure.h (v2)
Alon Bar-Lev indicated commit f27bf509315a48b0070294c3993a718df0c2626c was missing proper dependency checking. This patch corrects this and fixes an issue when creating configure.h via make distcheck. This is an enhanced version of the one sent to the openvpn-devel mailing list April 13, 2010 [1], after having received some feedback from Gert Doering, cleaning up configure_log.awk further. [1] <http://thread.gmane.org/gmane.network.openvpn.devel/3410/focus=3491> Signed-off-by: David Sommerseth <dazo@users.sourceforge.net> Acked-by: Gert Doering <gert@greenie.muc.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 20453d0..f509a4b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,7 +66,8 @@ dist_noinst_SCRIPTS = \
$(TESTS) \
doclean \
domake-win \
- t_cltsrv-down.sh
+ t_cltsrv-down.sh \
+ configure_h.awk configure_log.awk
dist_noinst_DATA = \
openvpn.spec \
@@ -141,9 +142,12 @@ openvpn_SOURCES = \
win32.h win32.c \
cryptoapi.h cryptoapi.c
+nodist_openvpn_SOURCES = configure.h
+options.$(OBJEXT): configure.h
+
configure.h: Makefile
- awk -f configure_h.awk config.h > $@
- awk -f configure_log.awk config.log >> $@
+ awk -f $(srcdir)/configure_h.awk config.h > $@
+ awk -f $(srcdir)/configure_log.awk config.log >> $@
clean-local:
-rm -f configure.h