summaryrefslogtreecommitdiffstats
path: root/plugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugin/CMakeLists.txt')
-rw-r--r--plugin/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/plugin/CMakeLists.txt b/plugin/CMakeLists.txt
index 8a1b43f..bf0202d 100644
--- a/plugin/CMakeLists.txt
+++ b/plugin/CMakeLists.txt
@@ -1,4 +1,4 @@
-PROJECT(eurephia-auth C)
+PROJECT(eurephia-plugin C)
cmake_minimum_required(VERSION 2.6)
SET(eurephia_auth_SRC
../common/certinfo.c
@@ -21,6 +21,10 @@ IF(FW_IPTABLES)
SET(subdirs firewall/iptables)
ENDIF(FW_IPTABLES)
+IF(ENABLE_EUREPHIADM)
+ REMOVE_DEFINITIONS(-DENABLE_EUREPHIADM)
+ENDIF(ENABLE_EUREPHIADM)
+
CHECK_LIBRARY_EXISTS(rt sem_wait "" HAVE_RT_SEM_WAIT)
CHECK_LIBRARY_EXISTS(rt sem_timedwait "" HAVE_RT_SEM_TIMEDWAIT)
CHECK_LIBRARY_EXISTS(rt sem_post "" HAVE_RT_SEM_POST)